TTH Inconsistency Error

Asked by Scott on 2009-09-20

Hi,

I'm connected to a local (lan) hub, but when people try to download files from me, half of the file transfers (exactly how much finishes varies on each instance), then the connection ends in a "TTH Inconsistency" error. Every minute after that, the connection tries again, but fails after a second. I've tried re-installing the program, re-hashing the files, and playing with the configuration settings, but the error still occurs. The problem seems somewhat random, some times, a file will transfer completely, other times it fails very quickly.

I'm on linuxdcpp version 1.0.3.

Thank you in advance,
Scott

Question information

Language:
English Edit question
Status:
Solved
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Solved by:
Razzloss
Solved:
2009-09-23
Last query:
2009-09-23
Last reply:
2009-09-22
Best Razzloss (razzloss) said : #1

If you're running on x86 or amd64 machine the TTH-code should work without problems. So this might be a hardware problem (hdd, memory or network card are the most likely culprits). Though it is also possible that the receiving end is the one with hw-problems, but if this happens with multiple people it is not likely.

I'd check the memory first with memtest86 as hdd problem isn't as probable if you've already rehashed everything.

--RZ

Scott (gatemansa) said : #2

Thanks for the response. After I posted this, my computer started randomly freezing, so I did a memory test (with memtest86), and it found 1200 errors, looks like you are right. Odd, since the ram is only a year old. On a side note, anyone know anything about warranty info for OCZ ram? Or what causes ram to fail?

Scott (gatemansa) said : #3

Thanks Razzloss, that solved my question.