OpChat

Asked by Tadies

hi...

im using version 1.0.2
also did try 1.0.3

but why can,t my fella Op's /admins can't see what i type in Opchat?
if the ohters does tpy i see all...
but they simply dont see my message ?

any ideas??

thnx!

Question information

Language:
English Edit question
Status:
Solved
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Solved by:
Razzloss
Solved:
Last query:
Last reply:
Revision history for this message
Razzloss (razzloss) said :
#1

Probably same thing as in a bug report filed a while ago. See: https://bugs.launchpad.net/linuxdcpp/+bug/405321

Most likely a wrong character encoding selected.

--RZ

Revision history for this message
Razzloss (razzloss) said :
#2

filed by you apparently...

Anyway the "weird" characters in opchat nickname, are probably discarded by linuxdcpp because you've selected the wrong encoding for the hub. When you try to send a message to the opchat, hub discards the message because the destination nick doesn't exist. The reason why it doesn't exist is the discarded characters, hub knows the destination by it's whole name, linuxdcpp tries to send it to the 'nick' with the incorrectly converted characters removed.

--RZ

Revision history for this message
Tadies (losslessexactoriginal) said :
#3

well its weird because i do use not a weird charatcer or anything
also i use latest ubuntu
and dc++ uses deafult system.....

so thats why im real lost.....

its a total new and clean install of ubuntu and linux dc++.....
the rest of linux dc is working fine... also the regular pm's to users etc does work fine.... only not the OpChat....
im real lost with this issue....

but im glad ya toke time to anwser so quick..... many kuddo's for that!

Revision history for this message
Best Razzloss (razzloss) said :
#4

Weird character in this case is anything non-ascii (7bit). eg. "safe characters" are a-z A-Z 0-9 and and few others (+-[])...

System default is probably UTF-8, which in most cases is the wrong choice for DC++. Try to change the hub specific encoding to CP1252 (if in western europe), CP1251 for eastern europe (if you know the encoding which is used in windows, then select that). You'll need to do this in the favorite hub properties for the saved hubs.

--RZ

Revision history for this message
Tadies (losslessexactoriginal) said :
#5

woooooTT now thats working awesome now....

many thnx for clarifie...... this did solve the issue!

gracias Razzloss!

Revision history for this message
Tadies (losslessexactoriginal) said :
#6

Thanks Razzloss, that solved my question.