files sharing on network

Asked by allonii on 2009-05-29

Hello!

I just installed linuxdc++ the problem is that I can't share files that are in my network.
This I was able to do in the regular dc++.

When I click on sharing, I can't find the network icon so I can add folders there from. Is there any solution to this?

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Solved by:
Steven Sheehy
Solved:
2009-06-01
Last query:
2009-06-01
Last reply:
2009-05-31
Steven Sheehy (steven-sheehy) said : #1

You probably need to mount your network drive so that GTK+ can find it. Use the mount command or put a line in your /etc/fstab so that it mounts on boot. It should show up when you browse for files after that.

allonii (allonii) said : #2

Hello Steven!

Well I have Ubuntu and I can see the drive mounted and ready to use on the desktop.
But When I open linuxdc++ I cant see it anymore?

Cheers

Best Steven Sheehy (steven-sheehy) said : #3

Try adding <property name="local_only">False</property> to glade/settingsdialog.glade under the "dirChooserDialog" widget item to see if that helps. If you installed linuxdcpp from Synaptic, that file will be at /usr/share/linuxdcpp/glade/ and will require sudo access to modify. It should look like this when you're done:

...
  <widget class="GtkFileChooserDialog" id="dirChooserDialog">
    <property name="local_only">False</property>
    <property name="title" translatable="yes">Choose a directory</property>
....

allonii (allonii) said : #4

Thanks man, now I can see the mounted hard drive.

Strange why do you have to do this manually?

allonii (allonii) said : #5

Thanks Steven Sheehy, that solved my question.