multiple instances

Asked by kranthi117 on 2009-01-25

when i open a magnet link with firefox, it tried to open a second instance of linux dc++. i was not able to find an option to force single instance mode.

any help will be appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Solved by:
kranthi117
Solved:
2009-01-26
Last query:
2009-01-26
Last reply:
2009-01-26
Razzloss (razzloss) said : #1

It should be single instance per config directory by default and starting 2 instances with same config should produce an error.

Currently what you are trying to do isn't possible (opening magnet link from firefox to search or for adding to queue) as LinuxDC++ won't accept links as cmd line arguments and there's no support for opening links in already running instance. You'll have to copy the link and paste it to mainchat or pm (you can pm yourself) and then click the link in linuxdc++.

--RZ

kranthi117 (kranthi117) said : #2

thanks.. when i open magnet link frm firefox linuxdcpp is not searching for that..(this used to happen in windows, i miss that functionality)... dnt notice this earlier..

but it is trying to open an other instance of linuxdcpp.. can you elaborate on that

Razzloss (razzloss) said : #3

LinuxDC++ is probably set as magnet handler somewhere and it is trying to open the magnet link by passing the link as an argument for linuxdcpp, which doesn't work and only starts a new instance of linuxdcpp. (starting linuxdcpp with any junk as command line argument just opens a new instance if one isn't running already)

--RZ

kranthi117 (kranthi117) said : #4

yeh i hav manually set it as a magnet handler in firefox.

but my question is that typing "linuxdcpp" at the command line is opening a new instance even if another instance of linuxdcpp is already running

Razzloss (razzloss) said : #5

I'm not sure that I understand anymore... Are you saying that when you type linuxdcpp it starts a new instance and doesn't show the error about already running instance? (and you are running 1.0.2 atleast)

--RZ

kranthi117 (kranthi117) said : #6

the above statement is partly true and partly false.

it is true that linuxdcpp is starting a new instance,
but i m using 1.0.1 not 1.0.2

Razzloss (razzloss) said : #7

Ok, then it is working as it should. Profile locking (== single instance/config) was added to 1.0.2.

--RZ

kranthi117 (kranthi117) said : #8

okkk..thanks for your replies...