Can't build 32 revision 0705-core branch

Asked by nucleo on 2008-11-27

When I try to build last revision of 0705-core on Fedora 8 I get this error

g++ -o build/gui/downloadqueue.o -c -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -I. -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_REENTRANT -D_DATADIR='"/usr/share"' -pthread -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -I/usr/include/libglade-2.0 -I/usr/include/gtk-2.0 -I/usr/include/libxml2 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include linux/downloadqueue.cc
./dcpp/Streams.h: In member function 'virtual size_t dcpp::LimitedOutputStream<managed>::write(const void*, size_t)':
./dcpp/Streams.h:140: error: there are no arguments to '_' that depend on a template parameter, so a declaration of '_' must be available
./dcpp/Streams.h:140: error: (if you use '-fpermissive', G++ will accept your code, but allowing the use of an undeclared name is deprecated)
scons: *** [build/gui/downloadqueue.o] Error 1
scons: building terminated because of errors.

$ gcc --version
gcc (GCC) 4.1.2 20070925 (Red Hat 4.1.2-33)

How can I fix it?

There are LinuxDC++ translations in /dcpp/po/*.
Why they are not used?

Question information

Language:
English Edit question
Status:
Solved
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Solved by:
Razzloss
Solved:
2008-11-28
Last query:
2008-11-28
Last reply:
2008-11-28
Razzloss (razzloss) said : #1

It seems that -fpermissive isn't specified if you don't build with release=1 or debug=1. So build with scons debug=1 or with scons release=1 + any other arguments you usually give to scons.

Transalations aren't used yet. Those translations are for the core messages and linuxdcpp will need it's own po files in addition, but adding localization won't be my problem (not touching that with a 20ft pole).

--RZ

Best Razzloss (razzloss) said : #2

Or just pull the latest revision (33). It should fix this.

--RZ

nucleo (nucleo) said : #3

Thanks Razzloss.
Revision 33 now builds.

nucleo (nucleo) said : #4

Thanks Razzloss, that solved my question.