Problem using umlaut characters in LinuxDC++

Asked by Hugo Gundewall on 2008-09-10

I am using Ubuntu 8.04 Hardy Heron and I cannot see Nordic characters such as å, ä & ö in LinuxDC++ (version 1.01). I have found tips on how to to circumvent the problem by typing the following in (I assume) the terminal:

_______________________________________________________________

"Type the following command to display the currently installed locales:

    locale -a

You will need ISO-8859-1 to display Swedish characters. Type:

    sudo dpkg-reconfigure locales

Move down the list and mark "sv_SE ISO-8859-1" with the space button. Press tab and choose "Ok". For the next screen, Default system environment locale, just choose "Ok". Your new locale will now be installed.

Issue the following command to start LinuxDC++ with Swedish locales:

$ env LC_ALL=sv_SE dcpp"
---------------------------------------------------------------------------------------------------

I do not understand however how to mark a list with the space button in the Terminal. Are they perhaps referring to some other kind of interface?

Question information

Language:
English Edit question
Status:
Answered
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Last query:
2008-09-10
Last reply:
2008-09-19
Steven Sheehy (steven-sheehy) said : #1

LinuxDC++ already has support for different character encodings built-in, there is no need to manually do it by changing your LC_ALL environment variable. In the preferences, change your default hub encoding to CP1252. Also, in the favorite hubs tab change each hub encoding to CP1252.

Actually CP1252 is preferable over ISO-8859-1, just as Steven says. The reason is that most clients visiting Nordic DC++ hubs are using THEIR default character encoding set. And that default happens to be CP1252.

Can you help with this problem?

Provide an answer of your own, or ask Hugo Gundewall for more information if necessary.

To post a message you must log in.