linux dc++ is blocked and I can't start it

Asked by Renato on 2014-06-07

Hello! I succesfully installed linux dc++ on ubuntu 12.04 and used it, but I connected to too many hubs or to some hub that isn't supported by linux dc++ and that blocks it, so when I start up the program now it automatically starts to load all the hubs, but then it close itself. It seems to be blocked/freezed to some hub that I connected in. I tryed to uninstall and reinstall it but it still continue to load the hubs and be freezed. I tryed to use these commands:
sudo dpkg --purge linuxdcpp
sudo dpkg -l | grep linuxdcpp
sudo apt-get dpkg -l | grep linuxdcpp
sudo apt-get purge linuxdcpp
sudo apt-get remove --purge linuxdcpp

but, as I said, nothing happened and it's still blocked. What can I do? How to completelly remove linuxdc++ configuration files, preferences, settings, hubs, etc.?

Question information

Language:
English Edit question
Status:
Solved
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Solved by:
Abe Froeman
Solved:
2014-06-10
Last query:
2014-06-10
Last reply:
2014-06-08
Abe Froeman (abe-froeman) said : #1

linuxdcpp will create a config folder in your home directory, IIRC something like .linuxdcpp (the period in front usually hides it from `ls`, so use `ls -lah` to show even hidden/files folders to find it). Delete that folder to remove all the settings you have saved.

Renato (arim-shanti) said : #2

In the home I didn't found .linuxdcpp but only ".dc++" and ".dc" folders. Do I have to delete both?

Best Abe Froeman (abe-froeman) said : #3

It is just the .dc++ folder, the .dc folder might be for another DC client. You can always look at the files inside the folders to be sure of what they are.

Renato (arim-shanti) said : #4

Thanks Abe Froeman, that solved my question.