Losing Share Located On USB Drive

Asked by nolarut on 2010-08-27

Hello, first off I wish to thank the Dev team for porting DC++ to Linux and I enjoy using the program. My problem is that I keep losing my share which is located on my USB drive after reboot (my USB drive is formatted in NTFS and I've also tried FAT32).

The only way I'm able to retain my share is if I hard code my USB drive partitions into FSTAB. This would not be a problem if I were using a desktop system but, I'm on a laptop and if I manually unmount my USB partitions in order to detach the drive, my computer won't boot up without the USB drive attached because the partitions are written into FSTAB.

I don't know if this is a DC++ issue, a user Linix skills issue or an NTFS-3g issue but since the program I'm having this issues with is DC++. I thought it might make sense to post here as maybe someone else has experienced this.

Looking forward to chatting with anyone who can help.

-Nolarut

Question information

Language:
English Edit question
Status:
Solved
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Solved by:
nolarut
Solved:
2010-08-27
Last query:
2010-08-27
Last reply:
2010-08-27
Razzloss (razzloss) said : #1

Why is the share lost? Does it mount it to a different location if it isn't hardcoded?

Anyway adding noauto to the fstab options for usb drives should solve the booting issue. That way they won't be automatically mounted at boot and you can mount them when you connect the USB HD.

--RZ

nolarut (nolarut) said : #2

I don't know how to quantify how to I solved this other than I updated to the latest version of Linuxdcpp via the ppa repo using tweak ubuntu and I removed all instances of my ntfs usb partitions in fstab.

Now my USB drive hot plugs on boot and I also can reboot the system without the drive attached as well. On cold reboot (with drive attached) the partitions with the shared folders needs to be accessed in order for them to mount and then my share shows up under my own list (no more zero byte share).

On reboot without drive attached, USB drive will hotplug and automount and the shared folders do show up.

Side Note: My Linux box is Linux Mint 9 XFCE.

If a beta tester is needed for new releases, please feel free to contact me.

-Nolarut

nolarut (nolarut) said : #3

Thanks for the timely reply Razzloss,

I don't know how to quantify how to I solved this other than I updated to the latest version of Linuxdcpp via the ppa repo using tweak ubuntu and I removed all instances of my ntfs usb partitions in fstab.

Now my USB drive hot plugs on boot and I also can reboot the system without the drive attached as well. On cold reboot (with drive attached) the partitions with the shared folders needs to be accessed in order for them to mount and then my share shows up under my own list (no more zero byte share).

On reboot without drive attached, USB drive will hotplug and automount and the shared folders do show up.

Side Note: My Linux box is Linux Mint 9 XFCE.

If a beta tester is needed for new releases, please feel free to contact me.

-Nolarut

nolarut (nolarut) said : #4

Apologies for the double post, as this is the first time I'm posting a question on Launchpad.