Linuxdc++ fills up swap space completely, even while not consuming more than 7M RAM space.

Asked by Ashish Sharma on 2010-04-28

I have been using linuxdcpp for a long time. It has worked for me without any problems. But for last couple of days I'm facing the following problem. When I start my linuxdc++ it loads fine but as then I just query the hub or make a search, the dc++ process starts filling up my swap disk making the system run slower with swap space completely filled.

I am having Ubuntu 9.10 with linuxdcpp version - 1.0.3-1 , swap space of 200MB.

Also if of any use,
$ uname -a
Linux topgun 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 05:23:09 UTC 2010 i686 GNU/Linux

Question information

Language:
English Edit question
Status:
Solved
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Solved by:
Steven Sheehy
Solved:
2010-04-29
Last query:
2010-04-29
Last reply:
2010-04-29
Best Steven Sheehy (steven-sheehy) said : #1

This may be related to bug #376896, which is caused by the kernel and its implementation of mmap. This would affect you while hashing and only while using the fast hash option. You may want to try with Ubuntu 10.04 when it comes out tomorrow.

Also, please try our latest unreleased binary in our PPA to see if it helps: https://launchpad.net/~linuxdcpp-team/+archive/ppa. At the very least this binary includes a setting that allows you to disable fast hashing (mmap) so you can see if it helps.

Ashish Sharma (ashishsharma) said : #2

Thanks for the information. I'll surely upgrade to new Ubuntu and linuxdcpp versions.

Ashish Sharma (ashishsharma) said : #3

Thanks Steven Sheehy, that solved my question.