Recommended hub software

Asked by jon


me again.

Still having some problems with uhub and linuxdc++. Everything works fine except if I turn on the option "tls_enable=yes", then it's impossible to connect.

Does anyone know if this is something lacking in implementation on the client side, or a bug on the server side? What I hope to achieve is that the hub ensures everyone is using ssl for transfers. As some users might be unable to make sure it's configured right I'd prefer the hub to make sure that's the case (I'd like to have it in the client too but can't seem to find any setting for that).

So, to cut things short: Is ssl properly configured in the client software and should this work, or is it a problem in the hub software? What hub software would you recommend for a server with 512MB of RAM and a slow VIA CPU?

Question information

English Edit question
LinuxDC++ Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Razzloss (razzloss) said :

I personally don't have any recommendations for hub software. I haven't used any other hubsoft than opendchub which I use for testing. And I haven't really bothered to check anything else. (you probably should not use opendchub in a 'production' environment).

Note that you should be using unreleased versions of Linuxdcpp (eg. compile the trunk or use our PPA's with debian based distros). Since the ADC(s) support isn't fully compatible with the latest ADC standard in the <0.700 cores which linuxdcpp 1.0.3 uses.

If the problem still occurs with latest linuxdcpp it can be because of a broken openssl library in either end. At least DSHub used a broken implementation of SSL which caused problems when connecting with working OpenSSL with TLS (you had to manually force the SSL3 mode to be able to connect such DSHubs). So either your linuxdcpp is using broken OpenSSL or your hub software. With Linuxdcpp you should be able to just upgrade your openssl packages (no recompilation of linuxdcpp should be needed). Not sure how uhub works.


Revision history for this message
jon (hardtofindname) said :

I'm using a compiled trunk, sorry for not mentioning the version:
        LinuxDC++ version: 1.0.3-bzr365
        DC++ Core version: 0.75
        GLIB header version: 2.22.4
        GLIB version: 2.22.4
        GTK header version: 2.18.6
        GTK version: 2.18.6

It's openssl 0.9.8n-1 on both the hub server and my workstation. I just had a friend try with dc++ (current stable, 0.761) in windows and it gives the same error in the uhub log:
2010-04-16 06:49:15 TRACE: Not TLS connection - closing connection.
2010-04-16 06:49:15 TRACE: net_cleanup_process: free: 0x9ba81f0

So it seems it's some sort of incompatibility between uhub and dc++. I'll try getting in touch with the uhub author and see the requirements for using the ssl related options.

Revision history for this message
jon (hardtofindname) said :

Seems like it was as with the last time, lack of reading up on my part that was the problem.

I wasn't aware I had to use "adcs://" in the address field instead of "adc://"...Hopefully have I got everything running now and I won't have to ask more stupid questions. Thanks for the reply, I tried with both uhub and luadch and it worked fine with both of them.