.Net Framework Initialization Error

Asked by singahdude on 2009-05-15

I tried Little Registry Cleaner at work today and it seemed to work just fine. Tonight, at home, I installed the program. When I try to launch, I get an error window:

Little Registry Cleaner.exe - .Net Framework Initialization Error
Please set registry key HKLM\Software\Microsoft\.NETFramework\Installroot to point to the .NET Framework install location.

What does this mean?

Question information

Language:
English Edit question
Status:
Answered
For:
Little Registry Cleaner Edit question
Assignee:
No assignee Edit question
Last query:
2009-05-15
Last reply:
2010-02-11
Nick (ub3rst4r) said : #1

This needs to be set to where the Microsoft .NET Framework is installed.

Go to start, run, enter "regedit" and press OK. Locate HKEY_LOCAL_MACHINE\Software\Microsoft\.NETFramework\Installroot and change it to where the framework is installed. Mine is set to "C:\Windows\Microsoft.NET\Framework64\".

Nick (ub3rst4r) said : #2

User never responded

jaygee_em (jaygee-em) said : #3

Seeing the date on this one, can I still comment? My daughter has had the exact same message after carrying out a complete system restore. So far it doesn't seem to affect the PC. I ran 'regedit' and got as far as ' HKLM\Software\Microsoft\..., but there was no sign of '.NETFramework etc. On my own machine it's exactly as Nick states on his.

Nick (ub3rst4r) said : #4

User posted ?

Nick (ub3rst4r) said : #5

Hi, I am on vacation but I will try to help as best I can. Please go to Google and search for ".net framework 3.5". Follow the links to the download link and try to install it. If that doesn't work than go to add/remove programs and look for "microsoft .net framework 3.5" and click on repair. Thanks

jaygee_em (jaygee-em) said : #6

Thanks for the advice. I won't be at my daughters for a few days, so I can't try this yet. Is it important as to which version of '.net framework' is used ? I could just copy the version on my PC and copy it to an identical location. We both run Win XP.

Nick (ub3rst4r) said : #7

Yes it must be v3.5. I wouldn't try moving your files because there are different types of the framework and theres a ton of files that it must use. This sort of sounds like a virus, I would do a scan using something like malwarebytes.org

Can you help with this problem?

Provide an answer of your own, or ask singahdude for more information if necessary.

To post a message you must log in.