would it be possible to get a version of lightspark for 10.04 LTS (lucid)

Asked by Anand Kumria on 2011-04-14

Hi,

I realise that you want to provide support for the latest and greatest Ubuntu version but would it also be possible to provide a version for Ubuntu 10.04 LTS (lucid).

I don't use Adobe's Flash instead only Lightspark and gnash.

And I'm now seeing 'you have an out-of-date Flash player' message everywhere.

Whereas before lightspark might try to run (or it would invoke Gnash).

Thanks,
Anand

Question information

Language:
English Edit question
Status:
Solved
For:
Lightspark Edit question
Assignee:
No assignee Edit question
Solved by:
Anand Kumria
Solved:
2011-05-07
Last query:
2011-05-07
Last reply:
2011-04-15

Hi,

to work correctly lightspark depends on libraries version more updated than the one provided in Lucid, for example libxml++ and mesa. As I cannot really maintain updated lucid compatible version for all those libraries Lightspark cannot be packaged for lucid either.

Sorry,
Alessandro Pignotti

Anand Kumria (wildfire) said : #2

OK, I am going to backport it myself.

https://launchpad.net/~wildfire/+archive/lightspark-lucid

Is where I will do it; I've found a few changes for the backport which I'll send separately.

Anand Kumria (wildfire) said : #3

And it works! Mostly.

You also seem to have discovered the same dependency changes I was going to send.

solidstate (jasdeckard) said : #4

Thanks!!!

I really appreciate your work to make a backport!!!

Humanurine (humanurine) said : #5

how do I get lightspark for Lucid, did you backport it? and how can I acces the page I get "not allowed here" in the lauchpad page.

pinzia (pinzia) said : #6

same problem for me: private page

Aleksey Lyalin (alyalin13) said : #7

pretty please