How do I set a VNC passwd in lightdm?

Asked by Doug Keester on 2012-05-30

I am trying to use the VNC functionality of LIghtDM. When I connect with my VNC client it is asking for a password. Where should such a password be set?

Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Light Display Manager Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-30
Last reply:
2013-09-19
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

V字龍(Vdragon) (vdragon) said : #2

I would like to ask the same question. Any LightDM developer like to answer it?

Robert Ancell (robert-ancell) said : #3

LightDM doesn't request that Xvnc (the X server used for VNC connections) use any specific authentication mechanism. So depending on what Xvnc you use, the server may use authentication by default.

From the xvnc4server package on Ubuntu and checking the man page shows it uses an authentication scheme by default, but this can be disabled by setting securitytypes=none on the command line. So to enable this in LightDM set the following in /etc/lightdm/lightdm.conf:

[VNCServer]
command=Xvnc securitytypes=none

Robert Ancell (robert-ancell) said : #4

(Answered in previous comment)

Can you help with this problem?

Provide an answer of your own, or ask Doug Keester for more information if necessary.

To post a message you must log in.