Password field not obscured

Asked by Ash on 2013-12-18

I am running lightdm-gtk-greeter v 1.6.1 in Debian, when I enter my password in the password field, the characters are not obscured.
See this screenshot for confirmation.
http://i.imgur.com/hPtvL1V.png

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
LightDM GTK+ Greeter Edit question
Assignee:
No assignee Edit question
Solved by:
Ash
Solved:
2013-12-29
Last query:
2013-12-29
Last reply:
2013-12-27
Simon SteinbeiƟ (ochosi) said : #1

Very strange,could you try to reproduce that with a different greeter? (e.g. unity-greeter)

Ash (flubba86) said : #2

Thanks for the reply Simon,

I did further testing using both lightdm-webkit-greeter and unity-greeter. Both display the password box correctly obscured.
See screenshot http://i.imgur.com/gSLcZzj.png of unity-greeter.

All password fields in other gtk2 and gtk3 applications on my system have correctly obscured fields, lightdm-gtk-greeter is the only instance this strange behaviour occurs.

I replaced my lightdm.conf and lightdm-gtk-greeter.conf files with default values, and the problem still occurs.

If I find some time, I might be able to download the package source and debug the problem locally on my system.

Ash (flubba86) said : #3

I have solved my problem. http://i.imgur.com/9UhC67O.png
There is a mistake in the lightdm-gtk-greeter.glade file.
There should be a property defined as <visibility>False</visibility>. This causes the entry box to be treated as a password field. Simply setting invisible_char and invisibale_char_set properties are not enough to cause the entry box to behave as an obscured password field.
I will create a bug for this, and submit my modified .glade file.

Simon SteinbeiƟ (ochosi) said : #4

Hey, have you already created a bugreport? If so (or even if not), please link to it here.
If you don't plan on creating a bugreport or a merge-request, I can also fix this in the glade-file myself, but then you won't be in the commit-log. So let me know how you wanna proceed.

Ash (flubba86) said : #5

I just linked in my bug report.
I included my fixed glade file in there, but it is not a patch or merge request.