incompatible version of diary?

Asked by mehtuus on 2017-08-07

I have a Lifeograph diary file that will not open. I stopped writing for a long while, but now I need to view the contents as well as to start writing again. I get an error now when trying to open the diary file. I believe that Lifeograph v0.6.3 (64bit) was the version used to create the file. Using Oracle VM VirtualBox (which only allows 32bit) I have tested with various versions and so far they all throw errors.

Using a hex editor to view the diary file I found this:
"LIFEOGRAPHDB V 56 E yes"

Based on a reply you gave to a similar question here (https://answers.launchpad.net/lifeograph/+question/173383), I deduced the following:
- LIFEOGRAPHDB V 56 = Lifeograph database v56, and that I "should be able to open it with Lifeograph 0.6.3".
- E yes = file is encrypted

Versions with which I tested and the error given:

- lifeograph_0.4.1-1_i386,
Password field is disabled. ERROR: "Corrupt or incompatible diary. Please select another file..."

- lifeograph_0.5.6-1_i386,
Password field is enabled, but after entering password throws this ERROR: "Selected diary is not compatible with this version of Lifograph. Please select another file..."

- lifeograph_0.6.3-1_i386,
Password field is enabled, but after entering password throws this ERROR: "Selected diary is not compatible with this version of Lifograph. Please select another file..."

- lifeograph_0.8.1.dfsg-1_i386,
Password field is enabled, but after entering the password a window pops up that says:
----------START WINDOW----------
Are You Sure You Want to Upgrade The Diary?
You are about to open an old diary that has to be upgraded to the new format.

It is STRONGLY recommended to back up any diary before upgrading.

After you upgrade a diary, you won't be able to open it in a previous version of Lifograph.
----------END WINDOW----------
The window allows me to "Cancel" or "Upgrade The Diary". When I choose to upgrade, it just goes back to the main enter password screen with my password still entered. When I click open the same upgrade window pops up again. It is stuck in this loop.

- lifeograph_0.8.2.dfsg-1_i386,
Password field is enabled, but after entering the password a window pops up that says:
----------START WINDOW----------
Are You Sure You Want to Upgrade The Diary?
You are about to open an old diary that has to be upgraded to the new format.

It is STRONGLY recommended to back up any diary before upgrading.

After you upgrade a diary, you won't be able to open it in a previous version of Lifograph.
----------END WINDOW----------
The window allows me to "Cancel" or "Upgrade The Diary". When I choose to upgrade, it just goes back to the main enter password screen with my password still entered. When I click open the same upgrade window pops up again. It is stuck in this loop.

- lifeograph_0.11.1.dfsg-1_i386,
-- When I browse to my file & open it via the "Read" button I'm asked for a password, but when I click the "OK" button the password window goes away but nothing else happens. The "Diaries" list window is still there, however it does NOT show the diary that I just attempted to open.
-- When I browse to my file & open it via the "Edit" button: I'm shown the popup window that says:
----------START WINDOW----------
Are You Sure You Want to Upgrade The Diary?
You are about to open an old diary that has to be upgraded to the new format.

It is STRONGLY recommended to back up any diary before upgrading.

After you upgrade a diary, you won't be able to open it in a previous version of Lifograph.
----------END WINDOW----------
The window allows me to "Cancel" or "Upgrade The Diary". When I choose upgrade, I'm prompted for the password but when I click "OK" it drops back to the "Diaries" list window. Again, it does NOT show the diary that I just attempted to open.

- lifeograph_0.11.1.dfsg-3_i386,
-- When I browse to my file & open it via the "Read" button I'm asked for a password, but when I click the "OK" button the password window goes away and Lifeograph immediately locked up. Tried again and it just went back to the "Diaries" list window just as before.
-- When I browse to my file & open it via the "Edit" button: I'm shown the popup window that says:
----------START WINDOW----------
Are You Sure You Want to Upgrade The Diary?
You are about to open an old diary that has to be upgraded to the new format.

It is STRONGLY recommended to back up any diary before upgrading.

After you upgrade a diary, you won't be able to open it in a previous version of Lifograph.
----------END WINDOW----------
The window allows me to "Cancel" or "Upgrade The Diary". When I choose upgrade, I'm prompted for the password but when I click "OK" it drops back to the "Diaries" list window. Again, it does NOT show the diary that I just attempted to open.

- Lifograph 1.3.0 (current version in my LinuxMint x64 installation),
When I browse to my file & open it via the "Read" OR the "Edit" button I'm not even asked for the password, it simply drops back to the "Diaries" list window with a "red bar" error across the top that says:
"Selected diary is in an older format which is not compatible with this version of Lifeograph. Please select another file..."

Any suggestions on what else can be done to open my diary file?

Question information

Language:
English Edit question
Status:
Answered
For:
Lifeograph Edit question
Assignee:
No assignee Edit question
Last query:
2017-08-07
Last reply:
2017-08-13
Ahmet Öztürk (dmxe) said : #1

I tried to open a v56 encrypted diary with Lifeograph 1.1.1 and succeded. But first I needed to compile v1.1.1 and to be able to do that I did some modifications to the source code. The last version that supports v56 diary files is 1.1.1. Any version before that down to 0.5.6 should work.
The repetitive password prompts may be due to wrong password entry. Are you sure you remember your password correctly?

Can you help with this problem?

Provide an answer of your own, or ask mehtuus for more information if necessary.

To post a message you must log in.