problem trying to make and install lifeograph

Asked by bill

I usually just accept the programs they give me at the ubuntu software center, but am finding they are often outdated. Going to the developer's site allows me to download more recent versions, but now i'm unsure what to do with it. I downloaded and extracted 1.2.1. When i say "make lifeograph" "make lifeograph-1.2.1" or "make lifeograph-1.2.1 ~/bill/" the terminal gives me the error "no rule to make target" Same thing when i use" make install"...

I've read this is easy but have yet to see the exact terminology employed. If someone would be kind enough to tell me the exact syntax to apply here, i would be very grateful and surely use it to gete updated versions of other programs. Many thanks!


Question information

English Edit question
Lifeograph Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Ahmet Öztürk (dmxe) said :

Please refer to the README file in the package. Basically, you should configure before make and you need to have cmake to be able to configure. Use the following commands to build:

 cmake -i .
 make install

Revision history for this message
Ruin Christmas (ruinchristmas) said :

Hello. I typed


and got:

- The C compiler identification is GNU 5.4.0
-- The CXX compiler identification is unknown
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
CMake Error at CMakeLists.txt:20 (project):
  No CMAKE_CXX_COMPILER could be found.

  Tell CMake where to find the compiler by setting either the environment
  variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
  to the compiler, or to the compiler name if it is in the PATH.


Please tell me what i need to do to install. I tried cmakecc and cmakegui version but also unsuccessful.

Revision history for this message
Fred (freddy-flintstone-09) said :

Tried the following with results
cmake -i .
     - followed the onsecreen prompts as defaults. all ok
     - nothing happened ??
make install
     - make: *** No rule to make target `install'. Stop.

OK. What did I do wrong this time?
PS These instructions are DIFFERENT from those in the README file !!!! Do i need to report a bug on this ?

Revision history for this message
Ahmet Öztürk (dmxe) said :

Actually "cmake -i ." was the old way. So, the README file is more correct. Please use "cmake -DCMAKE_INSTALL_PREFIX=/usr ."
Make sure that the output contains no error. And continue with make & make install.

Note: If you are using Ubuntu, the easiest way to make sure all the dependencies are intalled is:
sudo apt-get build-dep lifeograph

Revision history for this message
Fred (freddy-flintstone-09) said :

I did try the cmake -DCMAKE_INSTALL_PREFIX=/usr .
and I got a bunch of error messages, about 3 or pages worth

I just tried the sudo apt-get build-dep lifeograph and got "unable to find a source package for lifeograph"

I'm Linux Mint 17.3

Revision history for this message
Ertuğrul Harman (avert) said :

A short guide on how to build & compile Lifeograph (tested on debian):

Can you help with this problem?

Provide an answer of your own, or ask bill for more information if necessary.

To post a message you must log in.