lifeograph crashed. now when I cannot log into my "selected file because it is locked."

Asked by C. Brazill-LP

running a LT with ubuntu 12.04.1 64bit Gnome Shell 3.42 lifeograph 0.8.1

when I try to log into my encrypted file I get a message:
"selected file is locked, which means either it is being edited by another instance of Lifeograph or the last session with it did not finish correctly...."

pressing "open" will prompt me to "upgrade the diary", which when clicked doesn't to respond.

Any idea how i can either resolve this or retrieve my profile/diary?
as i mentioned it the profile is password protected /encrypted.

Question information

Language:
English Edit question
Status:
Solved
For:
Lifeograph Edit question
Assignee:
No assignee Edit question
Solved by:
Ahmet Öztürk
Solved:
Last query:
Last reply:
Revision history for this message
Best Ahmet Öztürk (dmxe) said :
#1

Go to the folder where the diary file is saved. Set the file manager, Nautilus I assume, to show the invisible files (shortcut is Ctrl+H, in Nautilus). There should be a LOCK file there, named like the diary file plus ~LOCK~ at the end. Rename that file to something else and open it in Lifeograph to check if it is healthy. If there is no problem with this file and it contains some edits not saved back to the original file you can replace your original diary file with it. But please note that in cases like this, it is better practise to keep the original diary file as a backup.

"pressing "open" will prompt me to "upgrade the diary", which when clicked doesn't to respond."
This was a bug in 0.8.1 and previous which has long since being fixed.

Revision history for this message
C. Brazill-LP (dragonlager) said :
#2

Thanks Ahmet Öztürk, that solved my question.