List functionality broken?

Asked by Vesal Vojdani

Hi, have you recently (since v0.8.1; also present in v0.8.2) done something to the list functionality? Previously, indent + * would turn into a bullet. Now, it does not, and although you can still get a bullet from the toolbar, it is not repeated for the next line...

Question information

Language:
English Edit question
Status:
Solved
For:
Lifeograph Edit question
Assignee:
No assignee Edit question
Solved by:
Vesal Vojdani
Solved:
Last query:
Last reply:
Revision history for this message
Ahmet Öztürk (dmxe) said :
#1

No, nothing. And it works for me just like ever before. May it be the case that you have changed some settings in your environment? This seems like a bug, anyway, but if you could now try 0.8.0 (the last working version for you) and confirm that it can still do what newer version can't on the very same machine, it would be really helpful in pinning down the cause of the problem.

Revision history for this message
Vesal Vojdani (vesal) said :
#2

Yes, well, after building it from sources it worked. Then, I also tried the binary package again, and it now miraculously works with that as well. (It did not work after purging the package and removing .config/lifeograph and re-installing binary package). Something must have changed when I built it from the sources. I had to install libgtkmm-2.4-dev and some of its dependencies, but I'm not sure how these could influence the binary package...

Anyway, it now works, but I don't think I can reproduce this problem. If it happens to me again or to anyone else, I can try to help you narrow down the problem.

Revision history for this message
Ahmet Öztürk (dmxe) said :
#3

Very glad to hear that. I guess, it's an incompatibility with some particular version of a library or a certain state of the environment, so to speak.