Problem compiling on Fedora 16 kde

Asked by ivar persson

I'm on Fedora 16 KDE, which uses .rpm packages and the latest package in the repos is 0.6.2 so I wanted to install from source.

Using the README instructions when I run ./waf configure I get the error:

Package gtkmm-2.4 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtkmm-2.4.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtkmm-2.4' found

I have checked and gtkmm 2.4 is installed under the paths:

This AFAIK is the standard path, but in case the program is looking under the wrong path, then how can I modify the "PKG_CONFIG_PATH environment variable" to reflect the correct location?

Additional info: the source directory in which I'm running configure is located under /home/ME/.Lifeograph/lifeograph 0.8.0

Question information

English Edit question
Lifeograph Edit question
No assignee Edit question
Solved by:
Ahmet Öztürk
Last query:
Last reply:
Revision history for this message
Best Ahmet Öztürk (dmxe) said :

For compilation you need *development versions* of the packages gtkmm, gtkspell, and gcrypt. In addition you will also need intltool for the build process to succeed.

Revision history for this message
ivar persson (bitter.lemon) said :

Thanks! that solved the problem. I have 0.8.0 installed now. Just need to figure out the uncompatible versions now.

Revision history for this message
ivar persson (bitter.lemon) said :

Thanks Ahmet Öztürk, that solved my question.