Libgrip example not working anymore when Ubuntu version changes

Asked by Bernard Victor Delvaux on 2013-03-28


I have compiled the 'rectangle-mover' example from the latest version of libgrip (0.3.5) on Ubuntu 12.10 and I can't have it working. However the very same binary file works perfectly on Ubuntu 11.10.
I have the same problem with this libgrip tutorial :
The example code compiles and works perfectly on Ubuntu 11.10; it compiles but doesn't work on Ubuntu 12.10.
In your opinion, could I have forgotten something? Is there something to change or to adjust to have it working?
Both Ubuntu versions are on the same laptop of course (Thinkpad T410s).

Thank you very much


Question information

English Edit question
libgrip Edit question
No assignee Edit question
Last query:
Last reply:
Stephen M. Webb (bregma) said : #1

Testing on a T410s with GEIS_DEBUG=3 set I see the following message on stderr.

  GEIS(debug)-_geis_grail_activate_with_filters:2338 filter 0x10fe500 'Pinch,touch=2' matches NO devices

I'm not sure if this is because support for semi-multitouch devices like the Synaptics touchpad in the T410s has changed or if there has been a bug introduced in the stack since 11.10 (I suspect the former).

This warrants further investigation.

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Stephen M. Webb (bregma) said : #3

Re-opening because an answer isstill under investigation.

Stephen M. Webb (bregma) said : #4

This appears to be a bug. I have opened #1168370 for further investigation and resolution.

Can you help with this problem?

Provide an answer of your own, or ask Bernard Victor Delvaux for more information if necessary.

To post a message you must log in.