i have deb files but doesn't know how to install in command(by using adb shell first)

Asked by Chen Chen on 2016-12-23

i have deb files but doesn't know how to install in command(by using adb shell first) ,
i can install it by copy to downloads and select installation files and then it stopped at installing for 10 min i wonder what happend so i got this idea :
can i install deb files with command????
Add tags Tag help
Chen Chen (cc243750496) wrote 40 minutes ago: #1

    freecad armhf deb for bq m10 Edit (18.2 MiB, application/x-debian-package)

Hide
Chen Chen (cc243750496) wrote 16 minutes ago: #2
Download full text (44.1 KiB)

phablet@ubuntu-phablet:~$ libertine-container-manager install-package -i myapps -p /home/phablet/Downloads/freecad.deb
Hit http://ppa.launchpad.net vivid InRelease
Hit http://ppa.launchpad.net vivid/main armhf Packages
Hit http://ppa.launchpad.net vivid/main Translation-en
Hit http://ports.ubuntu.com vivid InRelease
Hit http://ports.ubuntu.com vivid-updates InRelease
Hit http://ports.ubuntu.com vivid/main armhf Packages
Hit http://ports.ubuntu.com vivid/universe armhf Packages
Hit http://ports.ubuntu.com vivid/multiverse armhf Packages
Hit http://ports.ubuntu.com vivid/main Translation-en
Hit http://ports.ubuntu.com vivid/main Translation-en_GB
Hit http://ports.ubuntu.com vivid/multiverse Translation-en
Hit http://ports.ubuntu.com vivid/multiverse Translation-en_GB
Hit http://ports.ubuntu.com vivid/universe Translation-en
Hit http://ports.ubuntu.com vivid/universe Translation-en_GB
Hit http://ports.ubuntu.com vivid-updates/main armhf Packages
Hit http://ports.ubuntu.com vivid-updates/universe armhf Packages
Hit http://ports.ubuntu.com vivid-updates/multiverse armhf Packages
Hit http://ports.ubuntu.com vivid-updates/main Translation-en
Hit http://ports.ubuntu.com vivid-updates/multiverse Translation-en
Hit http://ports.ubuntu.com vivid-updates/universe Translation-en
Reading package lists... Done
ls: cannot access /home/phablet: No such file or directory
Selecting previously unselected package freecad.
(Reading database ... 26321 files and directories currently installed.)
Preparing to unpack /tmp/freecad.deb ...
Unpacking freecad (0.16+dfsg2-2) ...
dpkg: dependency problems prevent configuration of freecad:
 freecad depends on libsoqt4-20 (>= 1.6); however:
  Package libsoqt4-20 is not installed.
 freecad depends on python-collada; however:
  Package python-collada is not installed.
 freecad depends on python-matplotlib; however:
  Package python-matplotlib is not installed.
 freecad depends on python-pivy (>= 0.5.0~v609hg-2); however:
  Package python-pivy is not installed.
 freecad depends on python-ply; however:
  Package python-ply is not installed.
 freecad depends on python-pyside; however:
  Package python-pyside is not installed.
 freecad depends on pyside-tools; however:
  Package pyside-tools is not installed.
 freecad depends on python:any (>= 2.6.6-7~); however:
 freecad depends on python2.7; however:
  Package python2.7 is not installed.
 freecad depends on libboost-atomic1.62.0; however:
  Package libboost-atomic1.62.0 is not installed.
 freecad depends on libboost-chrono1.62.0; however:
  Package libboost-chrono1.62.0 is not installed.
 freeca
dpkg: error processing package freecad (--install):
 dependency problems - leaving unconfigured
Processing triggers for mime-support (3.58ubuntu1) ...
Process...

Question information

Language:
English Edit question
Status:
Needs information
For:
Libertine Edit question
Assignee:
No assignee Edit question
Last query:
2016-12-28
Last reply:
2017-01-18
Chen Chen (cc243750496) said : #1

phablet@ubuntu-phablet:~$ libertine-container-manager install-package -i myapps -p /home/phablet/Downloads/freecad.deb
Hit http://ppa.launchpad.net vivid InRelease
Hit http://ppa.launchpad.net vivid/main armhf Packages
Hit http://ppa.launchpad.net vivid/main Translation-en
Hit http://ports.ubuntu.com vivid InRelease
Hit http://ports.ubuntu.com vivid-updates InRelease
Hit http://ports.ubuntu.com vivid/main armhf Packages
Hit http://ports.ubuntu.com vivid/universe armhf Packages
Hit http://ports.ubuntu.com vivid/multiverse armhf Packages
Hit http://ports.ubuntu.com vivid/main Translation-en
Hit http://ports.ubuntu.com vivid/main Translation-en_GB
Hit http://ports.ubuntu.com vivid/multiverse Translation-en
Hit http://ports.ubuntu.com vivid/multiverse Translation-en_GB
Hit http://ports.ubuntu.com vivid/universe Translation-en
Hit http://ports.ubuntu.com vivid/universe Translation-en_GB
Hit http://ports.ubuntu.com vivid-updates/main armhf Packages
Hit http://ports.ubuntu.com vivid-updates/universe armhf Packages
Hit http://ports.ubuntu.com vivid-updates/multiverse armhf Packages
Hit http://ports.ubuntu.com vivid-updates/main Translation-en
Hit http://ports.ubuntu.com vivid-updates/multiverse Translation-en
Hit http://ports.ubuntu.com vivid-updates/universe Translation-en
Reading package lists... Done
ls: cannot access /home/phablet: No such file or directory
Selecting previously unselected package freecad.
(Reading database ... 26321 files and directories currently installed.)
Preparing to unpack /tmp/freecad.deb ...
Unpacking freecad (0.16+dfsg2-2) ...
dpkg: dependency problems prevent configuration of freecad:
 freecad depends on libsoqt4-20 (>= 1.6); however:
  Package libsoqt4-20 is not installed.
 freecad depends on python-collada; however:
  Package python-collada is not installed.
 freecad depends on python-matplotlib; however:
  Package python-matplotlib is not installed.
 freecad depends on python-pivy (>= 0.5.0~v609hg-2); however:
  Package python-pivy is not installed.
 freecad depends on python-ply; however:
  Package python-ply is not installed.
 freecad depends on python-pyside; however:
  Package python-pyside is not installed.
 freecad depends on pyside-tools; however:
  Package pyside-tools is not installed.
 freecad depends on python:any (>= 2.6.6-7~); however:
 freecad depends on python2.7; however:
  Package python2.7 is not installed.
 freecad depends on libboost-atomic1.62.0; however:
  Package libboost-atomic1.62.0 is not installed.
 freecad depends on libboost-chrono1.62.0; however:
  Package libboost-chrono1.62.0 is not installed.
 freeca
dpkg: error processing package freecad (--install):
 dependency problems - leaving unconfigured
Processing triggers for mime-support (3.58ubuntu1) ...
Processing triggers for shared-mime-info (1.3-1) ...
Errors were encountered while processing:
 freecad
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  fonts-lyx gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-pulseaudio gstreamer1.0-x javascript-common libaa1 libasound2
  libasound2-data libasyncns0 libavc1394-0 libblas-common libblas3 libcaca0
  libcdparanoia0 libdv4 libflac8 libfreeimage3 libgfortran3 libgl1-mesa-glx
  libglade2-0 libglu1-mesa libgomp1 libgstreamer-plugins-base1.0-0
  libgstreamer-plugins-good1.0-0 libgstreamer1.0-0 libiec61883-0 libilmbase6
  libjack-jackd2-0 libjs-jquery libjs-jquery-ui libjs-sphinxdoc
  libjs-underscore libjson-c2 liblapack3 libogg0 libopenexr6 libopenjpeg5
  libopus0 liborc-0.4-0 libphonon4 libpulse-mainloop-glib0 libpulse0
  libpyside1.2 libpython2.7 libqt4-dbus libqt4-help libqt4-opengl
  libqt4-scripttools libqt4-svg libqt4-test libqtwebkit4 libraw10
  libraw1394-11 libsamplerate0 libshiboken1.2 libshout3 libsndfile1 libspeex1
  libspnav0 libtag1-vanilla libtag1c2a libtheora0 libvisual-0.4-0
  libvisual-0.4-plugins libvorbis0a libvorbisenc2 libwavpack1 libwebp5
  libwebpmux1 libwrap0 libxcb-dri3-0 libxcb-glx0 libxcb-present0
  libxerces-c3.1 libxshmfence1 libxslt1.1 libxv1 libxxf86vm1 phonon
  phonon-backend-gstreamer phonon-backend-gstreamer-common pyside-tools
  python-bs4 python-cairo python-chardet python-collada python-dateutil
  python-glade2 python-gobject-2 python-gtk2 python-html5lib python-imaging
  python-lxml python-matplotlib python-matplotlib-data python-mock python-nose
  python-numpy python-pil python-pkg-resources python-ply python-pyparsing
  python-pyside python-pyside.phonon python-pyside.qtcore
  python-pyside.qtdeclarative python-pyside.qtgui python-pyside.qthelp
  python-pyside.qtnetwork python-pyside.qtopengl python-pyside.qtscript
  python-pyside.qtsql python-pyside.qtsvg python-pyside.qttest
  python-pyside.qtuitools python-pyside.qtwebkit python-pyside.qtxml
  python-six python-tz qdbus qtchooser tcpd
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  blt fonts-lyx gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-pulseaudio gstreamer1.0-x javascript-common libaa1 libasound2
  libasound2-data libasyncns0 libavc1394-0 libblas-common libblas3 libcaca0
  libcdparanoia0 libdv4 libflac8 libfreeimage3 libgfortran3 libgl1-mesa-glx
  libglade2-0 libglu1-mesa libgomp1 libgpm2 libgstreamer-plugins-base1.0-0
  libgstreamer-plugins-good1.0-0 libgstreamer1.0-0 libiec61883-0 libilmbase6
  libjack-jackd2-0 libjs-jquery libjs-jquery-ui libjs-sphinxdoc
  libjs-underscore libjson-c2 liblapack3 libogg0 libopenexr6 libopenjpeg5
  libopus0 liborc-0.4-0 libphonon4 libpulse-mainloop-glib0 libpulse0
  libpyside1.2 libpython-stdlib libpython2.7 libpython2.7-minimal
  libpython2.7-stdlib libqt4-dbus libqt4-help libqt4-opengl libqt4-scripttools
  libqt4-svg libqt4-test libqtwebkit4 libraw10 libraw1394-11 libsamplerate0
  libshiboken1.2 libshout3 libsndfile1 libspeex1 libspnav0 libtag1-vanilla
  libtag1c2a libtcl8.6 libtheora0 libtk8.6 libvisual-0.4-0
  libvisual-0.4-plugins libvorbis0a libvorbisenc2 libwavpack1 libwebp5
  libwebpmux1 libwrap0 libxcb-dri3-0 libxcb-glx0 libxcb-present0
  libxerces-c3.1 libxshmfence1 libxslt1.1 libxss1 libxv1 libxxf86vm1 phonon
  phonon-backend-gstreamer phonon-backend-gstreamer-common pyside-tools python
  python-bs4 python-cairo python-chardet python-collada python-dateutil
  python-glade2 python-gobject-2 python-gtk2 python-html5lib python-imaging
  python-lxml python-matplotlib python-matplotlib-data python-minimal
  python-mock python-nose python-numpy python-pil python-pkg-resources
  python-ply python-pyparsing python-pyside python-pyside.phonon
  python-pyside.qtcore python-pyside.qtdeclarative python-pyside.qtgui
  python-pyside.qthelp python-pyside.qtnetwork python-pyside.qtopengl
  python-pyside.qtscript python-pyside.qtsql python-pyside.qtsvg
  python-pyside.qttest python-pyside.qtuitools python-pyside.qtwebkit
  python-pyside.qtxml python-six python-tk python-tz python2.7
  python2.7-minimal qdbus qtchooser tcpd tk8.6-blt2.5
Suggested packages:
  blt-demo gvfs apache2 lighttpd httpd libasound2-plugins alsa-utils libdv-bin
  oss-compat gpm gstreamer1.0-tools jackd2 libjs-jquery-ui-docs opus-tools
  pulseaudio libraw1394-doc speex spacenavd tcl8.6 tk8.6
  phonon-backend-mplayer phonon-backend-vlc gstreamer1.0-plugins-ugly
  phonon4qt5-backend-gstreamer python-doc python-gtk2-doc python-gobject-2-dbg
  python-genshi python-lxml-dbg python-lxml-doc dvipng gir1.2-gtk-3.0
  ghostscript inkscape ipython python-cairocffi python-configobj
  python-excelerator python-gobject python-matplotlib-doc python-qt4
  python-scipy python-sip python-tornado python-traits python-wxgtk3.0
  texlive-extra-utils texlive-latex-extra ttf-staypuft python-mock-doc
  python-coverage python-nose-doc gcc gfortran python-dev python-numpy-dbg
  python-numpy-doc python-pil-doc python-pil-dbg python-distribute
  python-distribute-doc python-ply-doc tix python-tk-dbg python2.7-doc
  binutils binfmt-support
The following packages will be REMOVED:
  freecad
The following NEW packages will be installed:
  blt fonts-lyx gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-pulseaudio gstreamer1.0-x javascript-common libaa1 libasound2
  libasound2-data libasyncns0 libavc1394-0 libblas-common libblas3 libcaca0
  libcdparanoia0 libdv4 libflac8 libfreeimage3 libgfortran3 libgl1-mesa-glx
  libglade2-0 libglu1-mesa libgomp1 libgpm2 libgstreamer-plugins-base1.0-0
  libgstreamer-plugins-good1.0-0 libgstreamer1.0-0 libiec61883-0 libilmbase6
  libjack-jackd2-0 libjs-jquery libjs-jquery-ui libjs-sphinxdoc
  libjs-underscore libjson-c2 liblapack3 libogg0 libopenexr6 libopenjpeg5
  libopus0 liborc-0.4-0 libphonon4 libpulse-mainloop-glib0 libpulse0
  libpyside1.2 libpython-stdlib libpython2.7 libpython2.7-minimal
  libpython2.7-stdlib libqt4-dbus libqt4-help libqt4-opengl libqt4-scripttools
  libqt4-svg libqt4-test libqtwebkit4 libraw10 libraw1394-11 libsamplerate0
  libshiboken1.2 libshout3 libsndfile1 libspeex1 libspnav0 libtag1-vanilla
  libtag1c2a libtcl8.6 libtheora0 libtk8.6 libvisual-0.4-0
  libvisual-0.4-plugins libvorbis0a libvorbisenc2 libwavpack1 libwebp5
  libwebpmux1 libwrap0 libxcb-dri3-0 libxcb-glx0 libxcb-present0
  libxerces-c3.1 libxshmfence1 libxslt1.1 libxss1 libxv1 libxxf86vm1 phonon
  phonon-backend-gstreamer phonon-backend-gstreamer-common pyside-tools python
  python-bs4 python-cairo python-chardet python-collada python-dateutil
  python-glade2 python-gobject-2 python-gtk2 python-html5lib python-imaging
  python-lxml python-matplotlib python-matplotlib-data python-minimal
  python-mock python-nose python-numpy python-pil python-pkg-resources
  python-ply python-pyparsing python-pyside python-pyside.phonon
  python-pyside.qtcore python-pyside.qtdeclarative python-pyside.qtgui
  python-pyside.qthelp python-pyside.qtnetwork python-pyside.qtopengl
  python-pyside.qtscript python-pyside.qtsql python-pyside.qtsvg
  python-pyside.qttest python-pyside.qtuitools python-pyside.qtwebkit
  python-pyside.qtxml python-six python-tk python-tz python2.7
  python2.7-minimal qdbus qtchooser tcpd tk8.6-blt2.5
0 upgraded, 137 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 6,383 kB/38.9 MB of archives.
After this operation, 49.0 MB of additional disk space will be used.
Get:1 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-matplotlib armhf 1.4.2-3.1 [3,365 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports/ vivid/main python-ply all 3.4-5 [48.4 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qtgui armhf 1.2.2-1 [1,579 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.phonon armhf 1.2.2-1 [129 kB]
Get:5 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qtnetwork armhf 1.2.2-1 [158 kB]
Get:6 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qtdeclarative armhf 1.2.2-1 [71.2 kB]
Get:7 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qthelp armhf 1.2.2-1 [65.2 kB]
Get:8 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qtopengl armhf 1.2.2-1 [68.9 kB]
Get:9 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qtscript armhf 1.2.2-1 [63.2 kB]
Get:10 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qtsql armhf 1.2.2-1 [92.9 kB]
Get:11 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qtsvg armhf 1.2.2-1 [31.6 kB]
Get:12 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qttest armhf 1.2.2-1 [27.7 kB]
Get:13 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qtxml armhf 1.2.2-1 [116 kB]
Get:14 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qtuitools armhf 1.2.2-1 [172 kB]
Get:15 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside.qtwebkit armhf 1.2.2-1 [103 kB]
Get:16 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe python-pyside all 1.2.2-1 [4,462 B]
Get:17 http://ports.ubuntu.com/ubuntu-ports/ vivid/main python-tk armhf 2.7.9-1 [22.5 kB]
Get:18 http://ports.ubuntu.com/ubuntu-ports/ vivid/main tcpd armhf 7.6.q-25 [21.6 kB]
Get:19 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe libfreeimage3 armhf 3.15.4-4.1 [236 kB]
Get:20 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe libspnav0 armhf 0.2.2-1ubuntu1 [8,238 B]
Fetched 3,200 kB in 2min 10s (24.6 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 27198 files and directories currently installed.)
Removing freecad (0.16+dfsg2-2) ...
Processing triggers for shared-mime-info (1.3-1) ...
Processing triggers for mime-support (3.58ubuntu1) ...
Selecting previously unselected package libjson-c2:armhf.
(Reading database ... 26321 files and directories currently installed.)
Preparing to unpack .../libjson-c2_0.11-4ubuntu2_armhf.deb ...
Unpacking libjson-c2:armhf (0.11-4ubuntu2) ...
Selecting previously unselected package libgpm2:armhf.
Preparing to unpack .../libgpm2_1.20.4-6.1_armhf.deb ...
Unpacking libgpm2:armhf (1.20.4-6.1) ...
Selecting previously unselected package libaa1:armhf.
Preparing to unpack .../libaa1_1.4p5-43_armhf.deb ...
Unpacking libaa1:armhf (1.4p5-43) ...
Selecting previously unselected package libasound2-data.
Preparing to unpack .../libasound2-data_1.0.28-1_all.deb ...
Unpacking libasound2-data (1.0.28-1) ...
Selecting previously unselected package libasound2:armhf.
Preparing to unpack .../libasound2_1.0.28-1_armhf.deb ...
Unpacking libasound2:armhf (1.0.28-1) ...
Selecting previously unselected package libasyncns0:armhf.
Preparing to unpack .../libasyncns0_0.8-5build1_armhf.deb ...
Unpacking libasyncns0:armhf (0.8-5build1) ...
Selecting previously unselected package libcaca0:armhf.
Preparing to unpack .../libcaca0_0.99.beta19-2build1_armhf.deb ...
Unpacking libcaca0:armhf (0.99.beta19-2build1) ...
Selecting previously unselected package libcdparanoia0:armhf.
Preparing to unpack .../libcdparanoia0_3.10.2+debian-11_armhf.deb ...
Unpacking libcdparanoia0:armhf (3.10.2+debian-11) ...
Selecting previously unselected package libdv4:armhf.
Preparing to unpack .../libdv4_1.0.0-6_armhf.deb ...
Unpacking libdv4:armhf (1.0.0-6) ...
Selecting previously unselected package libogg0:armhf.
Preparing to unpack .../libogg0_1.3.2-1_armhf.deb ...
Unpacking libogg0:armhf (1.3.2-1) ...
Selecting previously unselected package libflac8:armhf.
Preparing to unpack .../libflac8_1.3.1-1ubuntu1_armhf.deb ...
Unpacking libflac8:armhf (1.3.1-1ubuntu1) ...
Selecting previously unselected package libgfortran3:armhf.
Preparing to unpack .../libgfortran3_4.9.2-10ubuntu13_armhf.deb ...
Unpacking libgfortran3:armhf (4.9.2-10ubuntu13) ...
Selecting previously unselected package libxcb-dri3-0:armhf.
Preparing to unpack .../libxcb-dri3-0_1.10-2ubuntu1_armhf.deb ...
Unpacking libxcb-dri3-0:armhf (1.10-2ubuntu1) ...
Selecting previously unselected package libxcb-glx0:armhf.
Preparing to unpack .../libxcb-glx0_1.10-2ubuntu1_armhf.deb ...
Unpacking libxcb-glx0:armhf (1.10-2ubuntu1) ...
Selecting previously unselected package libxcb-present0:armhf.
Preparing to unpack .../libxcb-present0_1.10-2ubuntu1_armhf.deb ...
Unpacking libxcb-present0:armhf (1.10-2ubuntu1) ...
Selecting previously unselected package libxshmfence1:armhf.
Preparing to unpack .../libxshmfence1_1.1-4_armhf.deb ...
Unpacking libxshmfence1:armhf (1.1-4) ...
Selecting previously unselected package libxxf86vm1:armhf.
Preparing to unpack .../libxxf86vm1_1%3a1.1.3-1_armhf.deb ...
Unpacking libxxf86vm1:armhf (1:1.1.3-1) ...
Selecting previously unselected package libgl1-mesa-glx:armhf.
Preparing to unpack .../libgl1-mesa-glx_10.5.9-2ubuntu1~vivid2_armhf.deb ...
Unpacking libgl1-mesa-glx:armhf (10.5.9-2ubuntu1~vivid2) ...
Selecting previously unselected package libglade2-0:armhf.
Preparing to unpack .../libglade2-0_1%3a2.6.4-2_armhf.deb ...
Unpacking libglade2-0:armhf (1:2.6.4-2) ...
Selecting previously unselected package libgomp1:armhf.
Preparing to unpack .../libgomp1_4.9.2-10ubuntu13_armhf.deb ...
Unpacking libgomp1:armhf (4.9.2-10ubuntu13) ...
Selecting previously unselected package libgstreamer1.0-0:armhf.
Preparing to unpack .../libgstreamer1.0-0_1.8.2-1~ubuntu2~overlay1_armhf.deb ...
Unpacking libgstreamer1.0-0:armhf (1.8.2-1~ubuntu2~overlay1) ...
Selecting previously unselected package libgstreamer-plugins-base1.0-0:armhf.
Preparing to unpack .../libgstreamer-plugins-base1.0-0_1.8.2-1ubuntu0.1~overlay1_armhf.deb ...
Unpacking libgstreamer-plugins-base1.0-0:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Selecting previously unselected package libraw1394-11:armhf.
Preparing to unpack .../libraw1394-11_2.1.0-3_armhf.deb ...
Unpacking libraw1394-11:armhf (2.1.0-3) ...
Selecting previously unselected package libiec61883-0:armhf.
Preparing to unpack .../libiec61883-0_1.2.0-0.2_armhf.deb ...
Unpacking libiec61883-0:armhf (1.2.0-0.2) ...
Selecting previously unselected package libilmbase6:armhf.
Preparing to unpack .../libilmbase6_1.0.1-6.1_armhf.deb ...
Unpacking libilmbase6:armhf (1.0.1-6.1) ...
Selecting previously unselected package libsamplerate0:armhf.
Preparing to unpack .../libsamplerate0_0.1.8-8_armhf.deb ...
Unpacking libsamplerate0:armhf (0.1.8-8) ...
Selecting previously unselected package libjack-jackd2-0:armhf.
Preparing to unpack .../libjack-jackd2-0_1.9.10+20140719git3eb0ae6a~dfsg-2_armhf.deb ...
Unpacking libjack-jackd2-0:armhf (1.9.10+20140719git3eb0ae6a~dfsg-2) ...
Selecting previously unselected package libopenexr6:armhf.
Preparing to unpack .../libopenexr6_1.6.1-8_armhf.deb ...
Unpacking libopenexr6:armhf (1.6.1-8) ...
Selecting previously unselected package libopus0:armhf.
Preparing to unpack .../libopus0_1.1-0ubuntu2_armhf.deb ...
Unpacking libopus0:armhf (1.1-0ubuntu2) ...
Selecting previously unselected package liborc-0.4-0:armhf.
Preparing to unpack .../liborc-0.4-0_1%3a0.4.22-1_armhf.deb ...
Unpacking liborc-0.4-0:armhf (1:0.4.22-1) ...
Selecting previously unselected package libvorbis0a:armhf.
Preparing to unpack .../libvorbis0a_1.3.4-2_armhf.deb ...
Unpacking libvorbis0a:armhf (1.3.4-2) ...
Selecting previously unselected package libvorbisenc2:armhf.
Preparing to unpack .../libvorbisenc2_1.3.4-2_armhf.deb ...
Unpacking libvorbisenc2:armhf (1.3.4-2) ...
Selecting previously unselected package libsndfile1:armhf.
Preparing to unpack .../libsndfile1_1.0.25-9.1ubuntu0.15.04.1_armhf.deb ...
Unpacking libsndfile1:armhf (1.0.25-9.1ubuntu0.15.04.1) ...
Selecting previously unselected package libwrap0:armhf.
Preparing to unpack .../libwrap0_7.6.q-25_armhf.deb ...
Unpacking libwrap0:armhf (7.6.q-25) ...
Selecting previously unselected package libpulse0:armhf.
Preparing to unpack .../libpulse0_1%3a6.0-0ubuntu9.25_armhf.deb ...
Unpacking libpulse0:armhf (1:6.0-0ubuntu9.25) ...
Selecting previously unselected package libpulse-mainloop-glib0:armhf.
Preparing to unpack .../libpulse-mainloop-glib0_1%3a6.0-0ubuntu9.25_armhf.deb ...
Unpacking libpulse-mainloop-glib0:armhf (1:6.0-0ubuntu9.25) ...
Selecting previously unselected package qtchooser.
Preparing to unpack .../qtchooser_52-gae5eeef-1_armhf.deb ...
Unpacking qtchooser (52-gae5eeef-1) ...
Selecting previously unselected package qdbus.
Preparing to unpack .../qdbus_4%3a4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1_armhf.deb ...
Unpacking qdbus (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Selecting previously unselected package libqt4-dbus:armhf.
Preparing to unpack .../libqt4-dbus_4%3a4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1_armhf.deb ...
Unpacking libqt4-dbus:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Selecting previously unselected package libphonon4:armhf.
Preparing to unpack .../libphonon4_4%3a4.8.3-0ubuntu2_armhf.deb ...
Unpacking libphonon4:armhf (4:4.8.3-0ubuntu2) ...
Selecting previously unselected package libpython2.7-minimal:armhf.
Preparing to unpack .../libpython2.7-minimal_2.7.9-2ubuntu3_armhf.deb ...
Unpacking libpython2.7-minimal:armhf (2.7.9-2ubuntu3) ...
Selecting previously unselected package libpython2.7-stdlib:armhf.
Preparing to unpack .../libpython2.7-stdlib_2.7.9-2ubuntu3_armhf.deb ...
Unpacking libpython2.7-stdlib:armhf (2.7.9-2ubuntu3) ...
Selecting previously unselected package libpython2.7:armhf.
Preparing to unpack .../libpython2.7_2.7.9-2ubuntu3_armhf.deb ...
Unpacking libpython2.7:armhf (2.7.9-2ubuntu3) ...
Selecting previously unselected package libshiboken1.2:armhf.
Preparing to unpack .../libshiboken1.2_1.2.2-1_armhf.deb ...
Unpacking libshiboken1.2:armhf (1.2.2-1) ...
Selecting previously unselected package libpyside1.2:armhf.
Preparing to unpack .../libpyside1.2_1.2.2-1_armhf.deb ...
Unpacking libpyside1.2:armhf (1.2.2-1) ...
Selecting previously unselected package libqt4-help:armhf.
Preparing to unpack .../libqt4-help_4%3a4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1_armhf.deb ...
Unpacking libqt4-help:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Selecting previously unselected package libqt4-opengl:armhf.
Preparing to unpack .../libqt4-opengl_4%3a4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1_armhf.deb ...
Unpacking libqt4-opengl:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Selecting previously unselected package libqt4-scripttools:armhf.
Preparing to unpack .../libqt4-scripttools_4%3a4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1_armhf.deb ...
Unpacking libqt4-scripttools:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Selecting previously unselected package libqt4-svg:armhf.
Preparing to unpack .../libqt4-svg_4%3a4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1_armhf.deb ...
Unpacking libqt4-svg:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Selecting previously unselected package libqt4-test:armhf.
Preparing to unpack .../libqt4-test_4%3a4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1_armhf.deb ...
Unpacking libqt4-test:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Selecting previously unselected package libxslt1.1:armhf.
Preparing to unpack .../libxslt1.1_1.1.28-2build2_armhf.deb ...
Unpacking libxslt1.1:armhf (1.1.28-2build2) ...
Selecting previously unselected package libqtwebkit4:armhf.
Preparing to unpack .../libqtwebkit4_2.3.2-0ubuntu7_armhf.deb ...
Unpacking libqtwebkit4:armhf (2.3.2-0ubuntu7) ...
Selecting previously unselected package libraw10:armhf.
Preparing to unpack .../libraw10_0.16.0-9_armhf.deb ...
Unpacking libraw10:armhf (0.16.0-9) ...
Selecting previously unselected package libspeex1:armhf.
Preparing to unpack .../libspeex1_1.2~rc1.1-1ubuntu1_armhf.deb ...
Unpacking libspeex1:armhf (1.2~rc1.1-1ubuntu1) ...
Selecting previously unselected package libtheora0:armhf.
Preparing to unpack .../libtheora0_1.1.1+dfsg.1-6_armhf.deb ...
Unpacking libtheora0:armhf (1.1.1+dfsg.1-6) ...
Selecting previously unselected package libshout3:armhf.
Preparing to unpack .../libshout3_2.3.1-3_armhf.deb ...
Unpacking libshout3:armhf (2.3.1-3) ...
Selecting previously unselected package libtag1-vanilla:armhf.
Preparing to unpack .../libtag1-vanilla_1.9.1-2.1ubuntu1_armhf.deb ...
Unpacking libtag1-vanilla:armhf (1.9.1-2.1ubuntu1) ...
Selecting previously unselected package libtcl8.6:armhf.
Preparing to unpack .../libtcl8.6_8.6.1-6ubuntu1_armhf.deb ...
Unpacking libtcl8.6:armhf (8.6.1-6ubuntu1) ...
Selecting previously unselected package libxss1:armhf.
Preparing to unpack .../libxss1_1%3a1.2.2-1_armhf.deb ...
Unpacking libxss1:armhf (1:1.2.2-1) ...
Selecting previously unselected package libtk8.6:armhf.
Preparing to unpack .../libtk8.6_8.6.1-3ubuntu2_armhf.deb ...
Unpacking libtk8.6:armhf (8.6.1-3ubuntu2) ...
Selecting previously unselected package libvisual-0.4-0:armhf.
Preparing to unpack .../libvisual-0.4-0_0.4.0-6_armhf.deb ...
Unpacking libvisual-0.4-0:armhf (0.4.0-6) ...
Selecting previously unselected package libwavpack1:armhf.
Preparing to unpack .../libwavpack1_4.70.0-1_armhf.deb ...
Unpacking libwavpack1:armhf (4.70.0-1) ...
Selecting previously unselected package libxerces-c3.1:armhf.
Preparing to unpack .../libxerces-c3.1_3.1.1-5.1~build0.15.04.1_armhf.deb ...
Unpacking libxerces-c3.1:armhf (3.1.1-5.1~build0.15.04.1) ...
Selecting previously unselected package libxv1:armhf.
Preparing to unpack .../libxv1_2%3a1.0.10-1_armhf.deb ...
Unpacking libxv1:armhf (2:1.0.10-1) ...
Selecting previously unselected package phonon-backend-gstreamer-common:armhf.
Preparing to unpack .../phonon-backend-gstreamer-common_4%3a4.8.2-0ubuntu1_armhf.deb ...
Unpacking phonon-backend-gstreamer-common:armhf (4:4.8.2-0ubuntu1) ...
Selecting previously unselected package gstreamer1.0-pulseaudio:armhf.
Preparing to unpack .../gstreamer1.0-pulseaudio_1.8.2-1ubuntu0.1~overlay1_armhf.deb ...
Unpacking gstreamer1.0-pulseaudio:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Selecting previously unselected package libavc1394-0:armhf.
Preparing to unpack .../libavc1394-0_0.5.4-2_armhf.deb ...
Unpacking libavc1394-0:armhf (0.5.4-2) ...
Selecting previously unselected package libgstreamer-plugins-good1.0-0:armhf.
Preparing to unpack .../libgstreamer-plugins-good1.0-0_1.8.2-1ubuntu0.1~overlay1_armhf.deb ...
Unpacking libgstreamer-plugins-good1.0-0:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Selecting previously unselected package libtag1c2a:armhf.
Preparing to unpack .../libtag1c2a_1.9.1-2.1ubuntu1_armhf.deb ...
Unpacking libtag1c2a:armhf (1.9.1-2.1ubuntu1) ...
Selecting previously unselected package gstreamer1.0-plugins-base:armhf.
Preparing to unpack .../gstreamer1.0-plugins-base_1.8.2-1ubuntu0.1~overlay1_armhf.deb ...
Unpacking gstreamer1.0-plugins-base:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Selecting previously unselected package gstreamer1.0-plugins-good:armhf.
Preparing to unpack .../gstreamer1.0-plugins-good_1.8.2-1ubuntu0.1~overlay1_armhf.deb ...
Unpacking gstreamer1.0-plugins-good:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Selecting previously unselected package phonon-backend-gstreamer:armhf.
Preparing to unpack .../phonon-backend-gstreamer_4%3a4.8.2-0ubuntu1_armhf.deb ...
Unpacking phonon-backend-gstreamer:armhf (4:4.8.2-0ubuntu1) ...
Selecting previously unselected package python2.7-minimal.
Preparing to unpack .../python2.7-minimal_2.7.9-2ubuntu3_armhf.deb ...
Unpacking python2.7-minimal (2.7.9-2ubuntu3) ...
Selecting previously unselected package python-minimal.
Preparing to unpack .../python-minimal_2.7.9-1_armhf.deb ...
Unpacking python-minimal (2.7.9-1) ...
Selecting previously unselected package python2.7.
Preparing to unpack .../python2.7_2.7.9-2ubuntu3_armhf.deb ...
Unpacking python2.7 (2.7.9-2ubuntu3) ...
Selecting previously unselected package libpython-stdlib:armhf.
Preparing to unpack .../libpython-stdlib_2.7.9-1_armhf.deb ...
Unpacking libpython-stdlib:armhf (2.7.9-1) ...
Processing triggers for hicolor-icon-theme (0.14-0ubuntu1) ...
Processing triggers for mime-support (3.58ubuntu1) ...
Setting up libpython2.7-minimal:armhf (2.7.9-2ubuntu3) ...
Setting up python2.7-minimal (2.7.9-2ubuntu3) ...
Setting up python-minimal (2.7.9-1) ...
Selecting previously unselected package python.
(Reading database ... 28243 files and directories currently installed.)
Preparing to unpack .../python_2.7.9-1_armhf.deb ...
Unpacking python (2.7.9-1) ...
Selecting previously unselected package libglu1-mesa:armhf.
Preparing to unpack .../libglu1-mesa_9.0.0-2_armhf.deb ...
Unpacking libglu1-mesa:armhf (9.0.0-2) ...
Selecting previously unselected package libopenjpeg5:armhf.
Preparing to unpack .../libopenjpeg5_1%3a1.5.2-3_armhf.deb ...
Unpacking libopenjpeg5:armhf (1:1.5.2-3) ...
Selecting previously unselected package libwebp5:armhf.
Preparing to unpack .../libwebp5_0.4.1-1.2_armhf.deb ...
Unpacking libwebp5:armhf (0.4.1-1.2) ...
Selecting previously unselected package libwebpmux1:armhf.
Preparing to unpack .../libwebpmux1_0.4.1-1.2_armhf.deb ...
Unpacking libwebpmux1:armhf (0.4.1-1.2) ...
Selecting previously unselected package tk8.6-blt2.5.
Preparing to unpack .../tk8.6-blt2.5_2.5.3+dfsg-1_armhf.deb ...
Unpacking tk8.6-blt2.5 (2.5.3+dfsg-1) ...
Selecting previously unselected package blt.
Preparing to unpack .../blt_2.5.3+dfsg-1_armhf.deb ...
Unpacking blt (2.5.3+dfsg-1) ...
Selecting previously unselected package fonts-lyx.
Preparing to unpack .../fonts-lyx_2.1.3-1_all.deb ...
Unpacking fonts-lyx (2.1.3-1) ...
Selecting previously unselected package gstreamer1.0-x:armhf.
Preparing to unpack .../gstreamer1.0-x_1.8.2-1ubuntu0.1~overlay1_armhf.deb ...
Unpacking gstreamer1.0-x:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Selecting previously unselected package javascript-common.
Preparing to unpack .../javascript-common_11_all.deb ...
Unpacking javascript-common (11) ...
Selecting previously unselected package libblas-common.
Preparing to unpack .../libblas-common_1.2.20110419-10_armhf.deb ...
Unpacking libblas-common (1.2.20110419-10) ...
Selecting previously unselected package libblas3.
Preparing to unpack .../libblas3_1.2.20110419-10_armhf.deb ...
Unpacking libblas3 (1.2.20110419-10) ...
Selecting previously unselected package libjs-jquery.
Preparing to unpack .../libjs-jquery_1.7.2+dfsg-3ubuntu2_all.deb ...
Unpacking libjs-jquery (1.7.2+dfsg-3ubuntu2) ...
Selecting previously unselected package libjs-jquery-ui.
Preparing to unpack .../libjs-jquery-ui_1.10.1+dfsg-1_all.deb ...
Unpacking libjs-jquery-ui (1.10.1+dfsg-1) ...
Selecting previously unselected package libjs-underscore.
Preparing to unpack .../libjs-underscore_1.7.0~dfsg-1ubuntu1_all.deb ...
Unpacking libjs-underscore (1.7.0~dfsg-1ubuntu1) ...
Selecting previously unselected package libjs-sphinxdoc.
Preparing to unpack .../libjs-sphinxdoc_1.2.3+dfsg-1ubuntu2_all.deb ...
Unpacking libjs-sphinxdoc (1.2.3+dfsg-1ubuntu2) ...
Selecting previously unselected package liblapack3.
Preparing to unpack .../liblapack3_3.5.0-4_armhf.deb ...
Unpacking liblapack3 (3.5.0-4) ...
Selecting previously unselected package libvisual-0.4-plugins:armhf.
Preparing to unpack .../libvisual-0.4-plugins_0.4.0.dfsg.1-7build1_armhf.deb ...
Unpacking libvisual-0.4-plugins:armhf (0.4.0.dfsg.1-7build1) ...
Selecting previously unselected package phonon:armhf.
Preparing to unpack .../phonon_4%3a4.8.3-0ubuntu2_armhf.deb ...
Unpacking phonon:armhf (4:4.8.3-0ubuntu2) ...
Selecting previously unselected package python-pyside.qtcore.
Preparing to unpack .../python-pyside.qtcore_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtcore (1.2.2-1) ...
Selecting previously unselected package pyside-tools.
Preparing to unpack .../pyside-tools_0.2.15-1_armhf.deb ...
Unpacking pyside-tools (0.2.15-1) ...
Selecting previously unselected package python-bs4.
Preparing to unpack .../python-bs4_4.3.2-2ubuntu2_all.deb ...
Unpacking python-bs4 (4.3.2-2ubuntu2) ...
Selecting previously unselected package python-cairo.
Preparing to unpack .../python-cairo_1.8.8-1ubuntu5_armhf.deb ...
Unpacking python-cairo (1.8.8-1ubuntu5) ...
Selecting previously unselected package python-pkg-resources.
Preparing to unpack .../python-pkg-resources_12.2-1_all.deb ...
Unpacking python-pkg-resources (12.2-1) ...
Selecting previously unselected package python-chardet.
Preparing to unpack .../python-chardet_2.3.0-1_all.deb ...
Unpacking python-chardet (2.3.0-1) ...
Selecting previously unselected package python-six.
Preparing to unpack .../python-six_1.9.0-1_all.deb ...
Unpacking python-six (1.9.0-1) ...
Selecting previously unselected package python-dateutil.
Preparing to unpack .../python-dateutil_2.2-2_all.deb ...
Unpacking python-dateutil (2.2-2) ...
Selecting previously unselected package python-lxml.
Preparing to unpack .../python-lxml_3.4.2-1_armhf.deb ...
Unpacking python-lxml (3.4.2-1) ...
Selecting previously unselected package python-numpy.
Preparing to unpack .../python-numpy_1%3a1.8.2-1ubuntu1_armhf.deb ...
Unpacking python-numpy (1:1.8.2-1ubuntu1) ...
Selecting previously unselected package python-collada.
Preparing to unpack .../python-collada_0.4-2_all.deb ...
Unpacking python-collada (0.4-2) ...
Selecting previously unselected package python-gobject-2.
Preparing to unpack .../python-gobject-2_2.28.6-12build1_armhf.deb ...
Unpacking python-gobject-2 (2.28.6-12build1) ...
Selecting previously unselected package python-gtk2.
Preparing to unpack .../python-gtk2_2.24.0-3ubuntu4_armhf.deb ...
Unpacking python-gtk2 (2.24.0-3ubuntu4) ...
Selecting previously unselected package python-glade2.
Preparing to unpack .../python-glade2_2.24.0-3ubuntu4_armhf.deb ...
Unpacking python-glade2 (2.24.0-3ubuntu4) ...
Selecting previously unselected package python-html5lib.
Preparing to unpack .../python-html5lib_0.999-3_all.deb ...
Unpacking python-html5lib (0.999-3) ...
Selecting previously unselected package python-pil:armhf.
Preparing to unpack .../python-pil_2.7.0-1_armhf.deb ...
Unpacking python-pil:armhf (2.7.0-1) ...
Selecting previously unselected package python-imaging.
Preparing to unpack .../python-imaging_2.7.0-1_all.deb ...
Unpacking python-imaging (2.7.0-1) ...
Selecting previously unselected package python-matplotlib-data.
Preparing to unpack .../python-matplotlib-data_1.4.2-3.1_all.deb ...
Unpacking python-matplotlib-data (1.4.2-3.1) ...
Selecting previously unselected package python-pyparsing.
Preparing to unpack .../python-pyparsing_2.0.3+dfsg1-1_all.deb ...
Unpacking python-pyparsing (2.0.3+dfsg1-1) ...
Selecting previously unselected package python-tz.
Preparing to unpack .../python-tz_2014.10~dfsg1-0ubuntu2~15.04.0_all.deb ...
Unpacking python-tz (2014.10~dfsg1-0ubuntu2~15.04.0) ...
Selecting previously unselected package python-mock.
Preparing to unpack .../python-mock_1.0.1-3_all.deb ...
Unpacking python-mock (1.0.1-3) ...
Selecting previously unselected package python-nose.
Preparing to unpack .../python-nose_1.3.4-2_all.deb ...
Unpacking python-nose (1.3.4-2) ...
Selecting previously unselected package python-matplotlib.
Preparing to unpack .../python-matplotlib_1.4.2-3.1_armhf.deb ...
Unpacking python-matplotlib (1.4.2-3.1) ...
Selecting previously unselected package python-ply.
Preparing to unpack .../python-ply_3.4-5_all.deb ...
Unpacking python-ply (3.4-5) ...
Selecting previously unselected package python-pyside.qtgui.
Preparing to unpack .../python-pyside.qtgui_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtgui (1.2.2-1) ...
Selecting previously unselected package python-pyside.phonon.
Preparing to unpack .../python-pyside.phonon_1.2.2-1_armhf.deb ...
Unpacking python-pyside.phonon (1.2.2-1) ...
Selecting previously unselected package python-pyside.qtnetwork.
Preparing to unpack .../python-pyside.qtnetwork_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtnetwork (1.2.2-1) ...
Selecting previously unselected package python-pyside.qtdeclarative.
Preparing to unpack .../python-pyside.qtdeclarative_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtdeclarative (1.2.2-1) ...
Selecting previously unselected package python-pyside.qthelp.
Preparing to unpack .../python-pyside.qthelp_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qthelp (1.2.2-1) ...
Selecting previously unselected package python-pyside.qtopengl.
Preparing to unpack .../python-pyside.qtopengl_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtopengl (1.2.2-1) ...
Selecting previously unselected package python-pyside.qtscript.
Preparing to unpack .../python-pyside.qtscript_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtscript (1.2.2-1) ...
Selecting previously unselected package python-pyside.qtsql.
Preparing to unpack .../python-pyside.qtsql_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtsql (1.2.2-1) ...
Selecting previously unselected package python-pyside.qtsvg.
Preparing to unpack .../python-pyside.qtsvg_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtsvg (1.2.2-1) ...
Selecting previously unselected package python-pyside.qttest.
Preparing to unpack .../python-pyside.qttest_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qttest (1.2.2-1) ...
Selecting previously unselected package python-pyside.qtxml.
Preparing to unpack .../python-pyside.qtxml_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtxml (1.2.2-1) ...
Selecting previously unselected package python-pyside.qtuitools.
Preparing to unpack .../python-pyside.qtuitools_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtuitools (1.2.2-1) ...
Selecting previously unselected package python-pyside.qtwebkit.
Preparing to unpack .../python-pyside.qtwebkit_1.2.2-1_armhf.deb ...
Unpacking python-pyside.qtwebkit (1.2.2-1) ...
Selecting previously unselected package python-pyside.
Preparing to unpack .../python-pyside_1.2.2-1_all.deb ...
Unpacking python-pyside (1.2.2-1) ...
Selecting previously unselected package python-tk.
Preparing to unpack .../python-tk_2.7.9-1_armhf.deb ...
Unpacking python-tk (2.7.9-1) ...
Selecting previously unselected package tcpd.
Preparing to unpack .../tcpd_7.6.q-25_armhf.deb ...
Unpacking tcpd (7.6.q-25) ...
Selecting previously unselected package libfreeimage3.
Preparing to unpack .../libfreeimage3_3.15.4-4.1_armhf.deb ...
Unpacking libfreeimage3 (3.15.4-4.1) ...
Selecting previously unselected package libspnav0.
Preparing to unpack .../libspnav0_0.2.2-1ubuntu1_armhf.deb ...
Unpacking libspnav0 (0.2.2-1ubuntu1) ...
Processing triggers for fontconfig (2.11.94-0ubuntu2~overlay2) ...
Setting up libjson-c2:armhf (0.11-4ubuntu2) ...
Setting up libgpm2:armhf (1.20.4-6.1) ...
Setting up libaa1:armhf (1.4p5-43) ...
Setting up libasound2-data (1.0.28-1) ...
Setting up libasound2:armhf (1.0.28-1) ...
Setting up libasyncns0:armhf (0.8-5build1) ...
Setting up libcaca0:armhf (0.99.beta19-2build1) ...
Setting up libcdparanoia0:armhf (3.10.2+debian-11) ...
Setting up libdv4:armhf (1.0.0-6) ...
Setting up libogg0:armhf (1.3.2-1) ...
Setting up libflac8:armhf (1.3.1-1ubuntu1) ...
Setting up libgfortran3:armhf (4.9.2-10ubuntu13) ...
Setting up libxcb-dri3-0:armhf (1.10-2ubuntu1) ...
Setting up libxcb-glx0:armhf (1.10-2ubuntu1) ...
Setting up libxcb-present0:armhf (1.10-2ubuntu1) ...
Setting up libxshmfence1:armhf (1.1-4) ...
Setting up libxxf86vm1:armhf (1:1.1.3-1) ...
Setting up libgl1-mesa-glx:armhf (10.5.9-2ubuntu1~vivid2) ...
update-alternatives: using /usr/lib/arm-linux-gnueabihf/mesa/ld.so.conf to provide /etc/ld.so.conf.d/arm-linux-gnueabihf_GL.conf (arm-linux-gnueabihf_gl_conf) in auto mode
Setting up libglade2-0:armhf (1:2.6.4-2) ...
Setting up libgomp1:armhf (4.9.2-10ubuntu13) ...
Setting up libgstreamer1.0-0:armhf (1.8.2-1~ubuntu2~overlay1) ...
Setcap worked! gst-ptp-helper is not suid!
Setting up libgstreamer-plugins-base1.0-0:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Setting up libraw1394-11:armhf (2.1.0-3) ...
Setting up libiec61883-0:armhf (1.2.0-0.2) ...
Setting up libilmbase6:armhf (1.0.1-6.1) ...
Setting up libsamplerate0:armhf (0.1.8-8) ...
Setting up libjack-jackd2-0:armhf (1.9.10+20140719git3eb0ae6a~dfsg-2) ...
Setting up libopenexr6:armhf (1.6.1-8) ...
Setting up libopus0:armhf (1.1-0ubuntu2) ...
Setting up liborc-0.4-0:armhf (1:0.4.22-1) ...
Setting up libvorbis0a:armhf (1.3.4-2) ...
Setting up libvorbisenc2:armhf (1.3.4-2) ...
Setting up libsndfile1:armhf (1.0.25-9.1ubuntu0.15.04.1) ...
Setting up libwrap0:armhf (7.6.q-25) ...
Setting up libpulse0:armhf (1:6.0-0ubuntu9.25) ...
Setting up libpulse-mainloop-glib0:armhf (1:6.0-0ubuntu9.25) ...
Setting up qtchooser (52-gae5eeef-1) ...
Setting up qdbus (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Setting up libqt4-dbus:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Setting up libphonon4:armhf (4:4.8.3-0ubuntu2) ...
Setting up libpython2.7-stdlib:armhf (2.7.9-2ubuntu3) ...
Setting up libpython2.7:armhf (2.7.9-2ubuntu3) ...
Setting up libshiboken1.2:armhf (1.2.2-1) ...
Setting up libpyside1.2:armhf (1.2.2-1) ...
Setting up libqt4-help:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Setting up libqt4-opengl:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Setting up libqt4-scripttools:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Setting up libqt4-svg:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Setting up libqt4-test:armhf (4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1) ...
Setting up libxslt1.1:armhf (1.1.28-2build2) ...
Setting up libqtwebkit4:armhf (2.3.2-0ubuntu7) ...
Setting up libraw10:armhf (0.16.0-9) ...
Setting up libspeex1:armhf (1.2~rc1.1-1ubuntu1) ...
Setting up libtheora0:armhf (1.1.1+dfsg.1-6) ...
Setting up libshout3:armhf (2.3.1-3) ...
Setting up libtag1-vanilla:armhf (1.9.1-2.1ubuntu1) ...
Setting up libtcl8.6:armhf (8.6.1-6ubuntu1) ...
Setting up libxss1:armhf (1:1.2.2-1) ...
Setting up libtk8.6:armhf (8.6.1-3ubuntu2) ...
Setting up libvisual-0.4-0:armhf (0.4.0-6) ...
Setting up libwavpack1:armhf (4.70.0-1) ...
Setting up libxerces-c3.1:armhf (3.1.1-5.1~build0.15.04.1) ...
Setting up libxv1:armhf (2:1.0.10-1) ...
Setting up phonon-backend-gstreamer-common:armhf (4:4.8.2-0ubuntu1) ...
Setting up gstreamer1.0-pulseaudio:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Setting up libavc1394-0:armhf (0.5.4-2) ...
Setting up libgstreamer-plugins-good1.0-0:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Setting up libtag1c2a:armhf (1.9.1-2.1ubuntu1) ...
Setting up gstreamer1.0-plugins-base:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Setting up gstreamer1.0-plugins-good:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Setting up phonon-backend-gstreamer:armhf (4:4.8.2-0ubuntu1) ...
Setting up python2.7 (2.7.9-2ubuntu3) ...
Setting up libpython-stdlib:armhf (2.7.9-1) ...
Setting up python (2.7.9-1) ...
Setting up libglu1-mesa:armhf (9.0.0-2) ...
Setting up libopenjpeg5:armhf (1:1.5.2-3) ...
Setting up libwebp5:armhf (0.4.1-1.2) ...
Setting up libwebpmux1:armhf (0.4.1-1.2) ...
Setting up tk8.6-blt2.5 (2.5.3+dfsg-1) ...
Setting up blt (2.5.3+dfsg-1) ...
Setting up fonts-lyx (2.1.3-1) ...
Setting up gstreamer1.0-x:armhf (1.8.2-1ubuntu0.1~overlay1) ...
Setting up javascript-common (11) ...
Setting up libblas-common (1.2.20110419-10) ...
Setting up libblas3 (1.2.20110419-10) ...
update-alternatives: using /usr/lib/libblas/libblas.so.3 to provide /usr/lib/libblas.so.3 (libblas.so.3) in auto mode
Setting up libjs-jquery (1.7.2+dfsg-3ubuntu2) ...
Setting up libjs-jquery-ui (1.10.1+dfsg-1) ...
Setting up libjs-underscore (1.7.0~dfsg-1ubuntu1) ...
Setting up libjs-sphinxdoc (1.2.3+dfsg-1ubuntu2) ...
Setting up liblapack3 (3.5.0-4) ...
update-alternatives: using /usr/lib/lapack/liblapack.so.3 to provide /usr/lib/liblapack.so.3 (liblapack.so.3) in auto mode
Setting up libvisual-0.4-plugins:armhf (0.4.0.dfsg.1-7build1) ...
Setting up phonon:armhf (4:4.8.3-0ubuntu2) ...
Setting up python-pyside.qtcore (1.2.2-1) ...
Setting up pyside-tools (0.2.15-1) ...
Setting up python-bs4 (4.3.2-2ubuntu2) ...
Setting up python-cairo (1.8.8-1ubuntu5) ...
Setting up python-pkg-resources (12.2-1) ...
Setting up python-chardet (2.3.0-1) ...
Setting up python-six (1.9.0-1) ...
Setting up python-dateutil (2.2-2) ...
Setting up python-lxml (3.4.2-1) ...
Setting up python-numpy (1:1.8.2-1ubuntu1) ...
Setting up python-collada (0.4-2) ...
Setting up python-gobject-2 (2.28.6-12build1) ...
Setting up python-gtk2 (2.24.0-3ubuntu4) ...
Setting up python-glade2 (2.24.0-3ubuntu4) ...
Setting up python-html5lib (0.999-3) ...
Setting up python-pil:armhf (2.7.0-1) ...
Setting up python-imaging (2.7.0-1) ...
Setting up python-matplotlib-data (1.4.2-3.1) ...
Setting up python-pyparsing (2.0.3+dfsg1-1) ...
Setting up python-tz (2014.10~dfsg1-0ubuntu2~15.04.0) ...
Setting up python-mock (1.0.1-3) ...
Setting up python-nose (1.3.4-2) ...
Setting up python-matplotlib (1.4.2-3.1) ...
Setting up python-ply (3.4-5) ...
Setting up python-pyside.qtgui (1.2.2-1) ...
Setting up python-pyside.phonon (1.2.2-1) ...
Setting up python-pyside.qtnetwork (1.2.2-1) ...
Setting up python-pyside.qtdeclarative (1.2.2-1) ...
Setting up python-pyside.qthelp (1.2.2-1) ...
Setting up python-pyside.qtopengl (1.2.2-1) ...
Setting up python-pyside.qtscript (1.2.2-1) ...
Setting up python-pyside.qtsql (1.2.2-1) ...
Setting up python-pyside.qtsvg (1.2.2-1) ...
Setting up python-pyside.qttest (1.2.2-1) ...
Setting up python-pyside.qtxml (1.2.2-1) ...
Setting up python-pyside.qtuitools (1.2.2-1) ...
Setting up python-pyside.qtwebkit (1.2.2-1) ...
Setting up python-pyside (1.2.2-1) ...
Setting up python-tk (2.7.9-1) ...
Setting up tcpd (7.6.q-25) ...
Setting up libfreeimage3 (3.15.4-4.1) ...
Setting up libspnav0 (0.2.2-1ubuntu1) ...
Refreshing the container's dynamic linker run-time bindings

Q1:do my command correct?
(libertine-container-manager install-package -i myapps -p /home/phablet/Downloads/freecad.deb)

Q2:why it is in tmp????
ls: cannot access /home/phablet: No such file or directory
Selecting previously unselected package freecad.
(Reading database ... 26321 files and directories currently installed.)
Preparing to unpack /tmp/freecad.deb ...

Q3:how to slove the dependence ? witch command ????by using
libertine-container-manager exec --command "apt-get install -f" --id myapps
??????????????????????????

doniks (kaabud-lp) said : #2

Q1: Looks good

Q2: I think the use of tmp is just an implementation detail - I wouldn't worry about it. Same with the unavailability of /home/phablet/ - I think its just not mounted during libertine-container-manager - again, nothing to worry

Q3: Well, the simple /answer/ is : You solve it by installing all the dependencies: I.e. supply all tbe debs that this deb depends on. Depending on the number of dependencies this might not be a very simple task. Where have you gotten the deb from? Is there any other place like a ppa or compiling from source how you could install that software? Is there no version of freecad contained in the archives?

Chen Chen (cc243750496) said : #3

Q1: AS u said now i am compling from source now but i get an issue how to copy or decompress the sorce to target(the file system in libertine ),btw i have installed all the depends in libertine

Q2:why there's no space in my tablet????
phablet@ubuntu-phablet:~$ sudo apt-get install build-essential cmake python python-matplotlib libtool libtool libcoin80-dev libxerces-c-dev libboost-dev libboost-filesystem-dev libboost-regex-dev libboost-program-options-dev libboost-signals-dev libboost-thread-dev libboost-python-dev libqt4-dev libqt4-opengl-dev qt4-dev-tools python-dev python-pyside pyside-tools liboce-foundation-dev liboce-modeling-dev liboce-ocaf-dev liboce-visualization-dev liboce-ocaf-lite-dev oce-draw libeigen3-dev libqtwebkit-dev libshiboken-dev libpyside-dev libode-dev swig libzipios++-dev libfreetype6 libfreetype6-dev libsimage-dev checkinstall python-qt4 doxygen libspnav-dev dh-make devscripts lintian

After this operation, 648 MB of additional disk space will be used.
E: You don't have enough free space in /var/cache/apt/archives/.

Q3:why could i compile from outside libertine with command (cd /Freecad && debuild ) if the Q2 sloved(if i have space now )
here is the wiki page
http://www.freecadweb.org/wiki/?title=CompileOnUnix

Chen Chen (cc243750496) said : #4

phablet@ubuntu-phablet:~$ libertine-container-manager exec --command "debuild ~/Downloads" --id myapps
debuild: fatal error at line 633:
cannot find readable debian/changelog anywhere!
Are you in the source code tree?
phablet@ubuntu-phablet:~$ libertine-container-manager exec --command "ls" --id myapps
bin etc lib mnt root sbin sys usr
boot home media opt run srv tmp var
phablet@ubuntu-phablet:~$ libertine-container-manager exec --command "ls /home" --id myapps
phablet@ubuntu-phablet:~$

btw: my installation file is in Downloads not in Freecad folder,and i am providing more info to Q1

Larry Price (larryprice) said : #5

My recommendation is to use `libertine-launch --id myapps bash` to open a bash terminal instead of separate `exec` calls when attempting to build the deb. Also, make sure that you are in the correct directory when running `debuild` as the command posted above implies that ~/Downloads is incorrect.

Chen Chen (cc243750496) said : #6

phablet@ubuntu-phablet:~$ libertine-launch --id myapps bashpasted: QXcbConnection: Could not connect to display
matchbox: can't open display! check your DISPLAY variable.

Chen Chen (cc243750496) said : #7

phablet@ubuntu-phablet:~$ libertine-launch --id myapps bash
pasted: QXcbConnection: Could not connect to display
matchbox: can't open display! check your DISPLAY variable.

Chen Chen (cc243750496) said : #8

Q2:why there's no space in my tablet???? what's wrong with my tablet?how to fix it????here is the output(i want to install depends)
phablet@ubuntu-phablet:~$ sudo apt-get install build-essential cmake python python-matplotlib libtool libtool libcoin80-dev libxerces-c-dev libboost-dev libboost-filesystem-dev libboost-regex-dev libboost-program-options-dev libboost-signals-dev libboost-thread-dev libboost-python-dev libqt4-dev libqt4-opengl-dev qt4-dev-tools python-dev python-pyside pyside-tools liboce-foundation-dev liboce-modeling-dev liboce-ocaf-dev liboce-visualization-dev liboce-ocaf-lite-dev oce-draw libeigen3-dev libqtwebkit-dev libshiboken-dev libpyside-dev libode-dev swig libzipios++-dev libfreetype6 libfreetype6-dev libsimage-dev checkinstall python-qt4 doxygen libspnav-dev dh-make devscripts lintian

After this operation, 648 MB of additional disk space will be used.
E: You don't have enough free space in /var/cache/apt/archives/.

Q3:why could i compile from outside libertine with command (cd /Freecad && debuild ) if the Q2 sloved(if i have space now )

Q4:how to remove all the depends on my tablet if my sloution is incorrect (install depends outside libertine),by using sudo apt-get autoremove???

doniks (kaabud-lp) said : #9

Q1: You posted the output of libertine-launch. Is that a question? You are inside the container after this command.

Q2: It very much sounds like you (1) made the root partition writable and (2) you started using apt to install and upgrade software directly in the root partition. Neither is supported by Canonical and in my personal experience (2) is likely to bring you soon into the situation that you will have to reflash the device.

Q3: I'm not sure what your question is. I guess Larry just answered it. If you still want to ask something then please reformulate since it's not clear.

Q4: I'm not sure what your question is. Did I answer it with Q2? If you still want to ask something then please reformulate since it's not clear.

Chen Chen (cc243750496) said : #10

phablet@ubuntu-phablet:~$ libertine-launch --id myapps bash
pasted: QXcbConnection: Could not connect to display
matchbox: can't open display! check your DISPLAY variable.

it seems that is an error and nothing happened (no new window opened from adb shell and if i run the command from tablet's terminal error still the same)

doniks (kaabud-lp) said : #11

> it seems that is an error
Nothing serious

> and nothing happened
a new bash shell was spawned. Compare your bash history (cursor up) before and after the command. Compare

ls /
ls /home/phablet

before and after the command. Compare the shells pid : echo $$ before and after. You are inside the container. It's just that the bash shell IN the container still looks like any other regular bash shell.

> (no new window opened
It's not supposed to open a new window. It's just supposed to start a new bash.

> from adb shell and if i run the command from tablet's terminal error still the same)

Chen Chen (cc243750496) said : #12

can i use dpkg or apt-get update or add ppa and all the often command on ubuntu
tablet after entered
libertine-launch --id myapps bash
?????
i mean after entered the command :
libertine-launch --id myapps bash
all the often command such as apt-get、dpkg -i、add ppa and etc daily often used command can be used smoothly ????

Chen Chen (cc243750496) said : #13

 Q2:What's the difference between these three commands??????
libertine-launch --id myapps bash
libertine-container-manager exec -c "bash"
libertine-container-manager exec -c "bash" --id myapps

doniks (kaabud-lp) said : #14

My knowledge on these details gets a bit vague .... Maybe someone else can give a more official answer.

I think, rather than using apt, apt-get, dpkg, add-apt, etc you should rather use the corresponding libertine-container-manager command. The other ones might also work to some degree, but especially if you ask for "smoothly", I suggest you stick to libertine-container-manager.

As for the three commands, it seems libertine-launch gives you a "user shell", i.e., your user id is phablet and the typical directories like ~/Documents are mounted. lcm exec on the other hand gives you more of a "root shell", i.e, no mounts and you appear as "root". Also, I think I heard once that exec is not really officially supported, meaning it's here right now, but maybe it might go away at some point? But then again, .... that's true for everything :).

Between the last two commands, I think you're just explicitly stating the container ID, which is relevant if you have multiple containers.

Chen Chen (cc243750496) said : #15

YRP:I think, rather than using apt, apt-get, dpkg, add-apt, etc you should rather use the corresponding libertine-container-manager command. The other ones might also work to some degree, but especially if you ask for "smoothly", I suggest you stick to libertine-container-manager.

My Q: i build deb for armhf but failed to install it , it request super user , and btw :can i use dpkg command to install the file???

Installing Debian package... FAILED!

*** Failed to install the package

Do you want to see the log file? [y]: y
dpkg: error: requested operation requires superuser privilege

Erasing temporary files...OK

Writing backup package...

Manfred Hampl (m-hampl) said : #16

Maybe prepending the command with sudo provides you with the required administrative authorizations. Try

libertine-container-manager exec --command "sudo apt-get install -f" --id myapps

Chen Chen (cc243750496) said : #17

can i use dpkg command to install the file???
libertine-container-manager exec --command "sudo dpkg -i *.deb" --id myapps

Larry Price (larryprice) said : #18

Chen - were you able to figure this out?

You shouldn't need sudo when running `exec`.

If you have the deb on the host system, you should be able to use `libertine-container-manager install-package -i container-id -p /path/to/package`.

If the deb is in your container somewhere, you should be able to run `libertine-container-manager exec -i container-id -c "dpkg -i /internal/path/to/package"`.

Can you help with this problem?

Provide an answer of your own, or ask Chen Chen for more information if necessary.

To post a message you must log in.