cant add ppa(unrecognized arguments)

Asked by Chen Chen on 2016-10-25

 my container name is myapps so the command is
libertine-container-manager configure -a add "ppa:freecad-maintainers/freecad-daily" -i myapps
then it show me

libertine-container-manager: error: unrecognized arguments: ppa:freecad-maintainers/freecad-daily

why it show me that ?something wrong with my grammar?
 thx in adv !

Question information

Language:
English Edit question
Status:
Solved
For:
Libertine Edit question
Assignee:
No assignee Edit question
Last query:
2016-10-25
Last reply:
2016-11-09
Manfred Hampl (m-hampl) said : #1

I think you have to use

libertine-container-manager configure -a add -n "ppa:freecad-maintainers/freecad-daily" -i myapps

Chen Chen (cc243750496) said : #2

have u ever tried to add that ppa to install freecad? why still can't locate
 i have already done the command libertine-container-manager update --id myapps
 it show me mktemp
mktemp:failed to create directory via template '/run/user/32011/confined/com.ubuntu.terminal/tmp.XXXXXXXXXX' no such file or directory
but while i type the command it show up ppa already added in container and when i checked while open the libertine ->My Applications->settings->manage container->Additional archives and PPAs
it(the ppa) show right there maybe successfully added but why shows up
mktemp:failed to create directory via template '/run/user/32011/confined/com.ubuntu.terminal/tmp.XXXXXXXXXX' no such file or directory
maybe failed to add in some part?and that' s the reason why caused
E:Unable to locate package freecad-daily?

Chen Chen (cc243750496) said : #3

i mean what is the reason why i cant locate the package and cant install it correctly i hope u can try the add command and give me an answer

does it only this ppa failed or both the other ppa also have the same issue?thx in adv

Larry Price (larryprice) said : #4

We solved this in the bug log. The initial issue was indeed incorrect syntax, but eventually we realized that the PPA in question does not provide packages for vivid+armhf.

Chen Chen (cc243750496) said : #5

Chen Chen (cc243750496) •
Libertine

    Overview Code Bugs Blueprints Translations Answers

cant add ppa(unrecognized arguments) Edit
Bug #1636392 reported by Chen Chen on 2016-10-25
6
This bug affects you Edit
Affects Status Importance Assigned to Milestone

  Libertine

Invalid

Undecided

  Unassigned

Also affects project (?) Also affects distribution/package
Edit
Bug Description

my container name is myapps so the command is
libertine-container-manager configure -a add "ppa:freecad-maintainers/freecad-daily" -i myapps
then it show me
libertine-container-manager: error: unrecognized arguments: ppa:freecad-maintainers/freecad-daily
why it show me that ?something wrong with my grammar?
 thx in adv !
Add tags Tag help
Chen Chen (cc243750496) wrote on 2016-10-25: #1

    IMG_0933.JPG Edit (1.8 MiB, image/jpeg)

Hide
Larry Price (larryprice) wrote on 2016-10-25: #2

The correct syntax in your case would be:

    libertine-container-manager configure -a add -n "ppa:freecad-maintainers/freecad-daily" -i myapps

You can use `libertine-container-manager --help` or `man libertine-container-manager` to determine the correct syntax in most cases.
Chen Chen (cc243750496) wrote on 2016-10-26: #3

have u ever tried to add that ppa to install freecad? why still can't locate
 i have already done the command libertine-container-manager update --id myapps
 it show me mktemp
mktemp:failed to create directory via template '/run/user/32011/confined/com.ubuntu.terminal/tmp.XXXXXXXXXX' no such file or directory
but while i type the command it show up ppa already added in container and when i checked while open the libertine ->My Applications->settings->manage container->Additional archives and PPAs
it(the ppa) show right there maybe successfully added but why shows up
mktemp:failed to create directory via template '/run/user/32011/confined/com.ubuntu.terminal/tmp.XXXXXXXXXX' no such file or directory
maybe failed to add in some part?and that' s the reason why caused
E:Unable to locate package freecad-daily?

i mean what is the reason why i cant locate the package and cant install it correctly i hope u can try the add command and give me an answer
does it only this ppa failed or both the other ppa also have the same issue?thx in adv
Hide
Larry Price (larryprice) wrote on 2016-10-26: #4

Looks like you're using the ubuntu-terminal-app. It's not currently possible to use libertine-container-manager directly with the ubuntu-terminal-app due to confinement, which is the issue you are seeing. One workaround is to use `ssh localhost` in `ubuntu-terminal-app` to get around this. You could also use another terminal emulator in a Unity 7 environment or SSH from another machine. Alternatively, you can install the `libertine` or `libertine-manager-app` GUI and use that to install applications.
Chen Chen (cc243750496) wrote on 2016-10-28: #5

    image.jpg Edit (2.7 MiB, image/jpeg)

could i use adb shell command instead? and could u please give me some more details about how to configure or do it, i havent really quite get that. much more thx!
Hide
Larry Price (larryprice) wrote on 2016-10-28: #6

It looks like you're trying to install freecad-daily on a vivid-based system. If you look at the freecad-daily PPA (https://launchpad.net/~freecad-maintainers/+archive/ubuntu/freecad-daily), you'll notice that they no longer build for vivid. You will probably need to compile and install freecad-daily from source if you want to use it in the current Touch ecosystem.

If you're curious, I was able to successfully install freecad-daily with the following commands on my zesty desktop machine:

    libertine-container-manager configure -a add -n "ppa:freecad-maintainers/freecad-daily" -i myapps
    libertine-container-manager update -i myapps
    libertine-container-manager install-package -i myapps -p freecad-daily

Marking as Invalid.
Changed in libertine:
status: New → Invalid
Chen Chen (cc243750496) wrote on 2016-10-29: #7

 i know it but on desktop version we can set to configure to install 14.04' s version so are there anyway to configure it on mobile?or any other solutions maybe waiting for 15.10 upgrade?
Hide
Chen Chen (cc243750496) wrote on 2016-10-29: #8

You will probably need to compile and install freecad-daily from source if you want to use it in the current Touch ecosystem.

reply:how to install deb pacages to libertine mobile device
 any solutions? ( i know how to build deb from source but dont know how to transfer itto tablet and use what kind of command to install it )
btw i am so newbee so i hope u can tould me step by step
Hide
Chen Chen (cc243750496) wrote on 2016-10-29: #9

and i know its on arm
so shall i need something difference from build amd64 version(from install depends(maybe arm depends?) to compile)
Hide
Chen Chen (cc243750496) wrote on 2016-10-30: #10
Download full text (4.0 KiB)

and why Hash Sum mismatch??????????????
phablet@ubuntu-phablet:~/.local/share/libertine$ libertine-container-manager update --id myapps
Hit http://ports.ubuntu.com vivid InRelease
Hit http://ppa.launchpad.net vivid InRelease
Hit http://ports.ubuntu.com vivid-updates InRelease
Get:1 http://ports.ubuntu.com vivid/main armhf Packages [5,710 kB]
Get:2 http://ppa.launchpad.net vivid InRelease [15.4 kB]
Hit http://ports.ubuntu.com vivid/universe armhf Packages
Get:3 http://ppa.launchpad.net vivid InRelease [15.4 kB]
Get:4 http://ppa.launchpad.net vivid InRelease [15.5 kB]
Get:5 http://ppa.launchpad.net vivid InRelease [20.9 kB]
Get:6 http://ppa.launchpad.net vivid InRelease [16.0 kB]
Get:7 http://ppa.launchpad.net vivid/main armhf Packages [1,263 B]
Get:8 http://ppa.launchpad.net vivid/main Translation-en [3,589 B]
Get:9 http://ppa.launchpad.net vivid/main armhf Packages [1,263 B]
Get:10 http://ppa.launchpad.net vivid/main Translation-en [1,556 B]
Get:11 http://ppa.launchpad.net vivid/main armhf Packages [1,263 B]
Get:12 http://ppa.launchpad.net vivid/main Translation-en [14 B]
Hit http://ports.ubuntu.com vivid/multiverse armhf Packages
Hit http://ports.ubuntu.com vivid/main Translation-en
Get:13 http://ppa.launchpad.net vivid/main Translation-en [1,556 B]
Get:14 http://ppa.launchpad.net vivid/main armhf Packages [14 B]
Hit http://ports.ubuntu.com vivid/multiverse Translation-en
Get:15 http://ppa.launchpad.net vivid/main armhf Packages [3,324 B]
Hit http://ports.ubuntu.com vivid/universe Translation-en
Get:16 http://ppa.launchpad.net vivid/main Translation-en [8,285 B]
Hit http://ports.ubuntu.com vivid-updates/main armhf Packages
Get:17 http://ppa.launchpad.net vivid/main armhf Packages [3,324 B]
Hit http://ports.ubuntu.com vivid-updates/universe armhf Packages
Get:18 http://ppa.launchpad.net vivid/main Translation-en [8,285 B]
Hit http://ports.ubuntu.com vivid-updates/multiverse armhf Packages
Hit http://ports.ubuntu.com vivid-updates/main Translation-en
Hit http://ports.ubuntu.com vivid-updates/multiverse Translation-en
Hit http://ports.ubuntu.com vivid-updates/universe Translation-en
Fetched 5,827 kB in 16s (344 kB/s)
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/vivid/main/binary-armhf/Packages Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/ci-train-ppa-service/stable-phone-overlay/ubuntu/dists/vivid/main/binary-armhf/Packages Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/ci-train-ppa-service/stable-phone-overlay/ubuntu/dists/vivid/main/i18n/Translation-en Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/dhor/myway/ubuntu/dists/vi...

Read more...
Hide
Larry Price (larryprice) wrote on 2016-10-31: #11

You'll need to compile for armhf. If you have the space on your device, you could build/install the deb directly in the libertine container. Use `libertine-launch myapps bash` to start a session, and then you can pull down the source and build the deb like you would in a normal environment. Still within the bash session, you can run `dpkg -i foobar.deb` to install the package in your container.
Chen Chen (cc243750496) wrote on 2016-11-01: #12

W: Failed to fetch http://ppa.launchpad.net/dhor/myway/ubuntu/dists/vivid/main/binary-armhf/Packages Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/dhor/myway/ubuntu/dists/vivid/main/i18n/Translation-en Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/libreoffice/ppa/ubuntu/dists/vivid/main/binary-armhf/Packages Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/otto-kesselgulasch/gimp-edge/ubuntu/dists/vivid/main/i18n/Translation-en Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/scribus/ppa/ubuntu/dists/vivid/main/binary-armhf/Packages Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/scribus/ppa/ubuntu/dists/vivid/main/i18n/Translation-en Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/thomas-schiex/blender/ubuntu/dists/vivid/main/binary-armhf/Packages Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/thomas-schiex/blender/ubuntu/dists/vivid/main/i18n/Translation-en Hash Sum mismatch
Hide
Chen Chen (cc243750496) wrote on 2016-11-01: #13

why those ppa worked fine without 'hash sum mismatch' but shows up on my tablet????
anything wrong?
Hide
Larry Price (larryprice) wrote on 2016-11-02: #14

None of those PPAs are supported on vivid.

As this is straying from the original bug, I recommend using https://askubuntu.com for further support.
See full activity log
Add comment
Add attachment or patch

    Report a bug

This report contains Public information Edit
Everyone can see this information.

    Mark as duplicate
    Convert to a question
    Link a related branch
    Link to CVE

You are subscribed to all notifications for this bug.

    Mute bug mailMute help
    Edit bug mail

Other bug subscribers
Subscribe someone else
May be notified

    Christopher Townsend
    Larry Price
    Libertine Developers
    Michael Rowland H...
    Mitsuya Shibata
    krusty

Related questions

    Libertine: cant add ppa(unrecognized arguments)

Bug attachments

    IMG_0933.JPG (edit)
    image.jpg (edit)

    Add attachment

Launchpad • Take the tour • Read the guide
© 2004-2016 Canonical Ltd. • Terms of use • Contact Launchpad Support • Blog • Careers • System status • r18298 (Get the code!)