Failed to boot, can't find /dev in /etc/fstab

Asked by Syed Armani on 2012-01-31

When i rebooted the system, it failed to boot with the following message:
Mounting virtual file systems: /run /proc /sys /devmount : can't find /dev in /etc/fstab or /etc/mtab
ln: failed to create symbolic link '/dev/shm' : Read only file system
cp: cannot remove '/dev/null': Read-only file system

Failure:
unforseen error took place in /etc/rc.d/rcs.d/S00mountvirtfs
which exited with a return value of 1

Question information

Language:
English Edit question
Status:
Solved
For:
LFScript Edit question
Assignee:
No assignee Edit question
Solved by:
Marcel van den Boer
Solved:
2012-03-31
Last query:
2012-03-31
Last reply:
2012-01-31

The required contents of fstab changed a few days ago. The documentation is in the process of being updated.

Add the following line to your /etc/fstab:

    devtmpfs /dev devtmpfs mode=0755,nosuid 0 0

Bryn Nobbs (bryn-nobbs) said : #2

i have just ran into this exact same problem, adding that line has not fixed it, i just get the error unknown filesystem type devtmpfs

Bryn Nobbs (bryn-nobbs) said : #3

i just found this in the kernel configuration, im just enabling and recompiling my kernel to see how it goes

Device Drivers --->
  Generic Driver Options --->
     Maintain a devtmpfs filesystem to mount at / dev

Yes, you also need devtmpfs support in your kernel. Again, this requirement has only been added to LFS recently.

I'll be sure to add this info to the documentation.

Bryn Nobbs (bryn-nobbs) said : #5

this fixed it for me

Syed Armani (dce3062) said : #6

Thanks Marcel van den Boer, that solved my question.