How to add a json file from command line to a private/personal or private/team bundlestream

Asked by Prince Mathew on 2011-12-10

I am just using the LAVA Dashboard (and tool) features.
I want to add a json file to a private/personal or private/team bundles.
How do I do this ? (how do i give the username and password using lc-tool put command)

Question information

Language:
English Edit question
Status:
Solved
For:
LAVA Dashboard (deprecated) Edit question
Assignee:
No assignee Edit question
Solved by:
Prince Mathew
Solved:
2011-12-11
Last query:
2011-12-11
Last reply:
2011-12-10
Zygmunt Krynicki (zyga) said : #1

The procedure is the same as with anonymous bundle streams with two exceptions:

1) You need to generate an authentication token (go to API -> Authentication Tokens, create one and save the secret value somewhere for a brief moment)

2) You need to use lava-tool auth-add command to associate the token with a API URL. The important part is to include your username in the URL. Instead of, say, http://192.168.1.2/lava-server/RPC2/ you have to say http://myusername@192.168.1.2/lava-server/RPC2/ Your username is you launchpad username or your local account name (depending on how you log in).

Once you have authenticated you can invoke any RPC methods as yourself. The next time you send a bundle to the dashboard simply use the appropriate dashboard URL (the one with your account name)

Prince Mathew (princemat007) said : #2
Prince Mathew (princemat007) said : #3

1) created a new token

2) auth-add command executed
lc-tool auth-add http://username@localhost/lava-server/RPC2/

3) tried uploading a bundle.
->
lc-tool put --dashboard-url http://username@localhost/launch-control/xml-rpc/ ~/logs/test.json /private/personal/username/234234/
Not able to access the bundle (gives an error that the bundle doesnt exists even though it exists)
-------------
even
->
lc-tool bundle command
lc-tool put --dashboard-url http://username@localhost/launch-control/xml-rpc/ /private/personal/username/234234/
gives bundle doesnt exist.
-----------------
But the command below
->
lc-tool put --dashboard-url http://username@localhost/launch-control/xml-rpc/ ~/logs/test.json /anonymous/name/
->gets the bundle uploaded but the user is shown as NONE

What could be the problem with detecting the user?

Zygmunt Krynicki (zyga) said : #4

Launch Control is not supported. Please upgrade to lava-server and lava-dashboard. Everything I just told you should work there.

(we really should upgrade install instructions NOT to reference launch-control anymore)

Prince Mathew (princemat007) said : #5

Thank you :)