Under Hardy build fails due to: QtDBus: No such file or directory

Asked by hakaishi

My Qt4 program needs the libqt4-dbus -package. But under Hardy this package is ignored... (though it is in the backports http://packages.ubuntu.com/ca/hardy-backports/libqt4-dbus)
The buildlog shows:
error: QtDBus: No such file or directory
Most likely I just have to adjust something in the control-file.... - but what?
Please tell me XD

My control-file looks like this:
Source: qt-shutdown-p
Section: utils
Priority: optional
Maintainer: hakaishi <xxx>
XSBC-Original-Maintainer: hakaishi <xxx>
Build-Depends: debhelper (>= 5), libqt4-dev
Standards-Version: 3.8.3

Package: qt-shutdown-p
Version: 1.6
Architecture: all
Depends: ${shlibs:Depends}, ${misc:Depends}
Installed-Size: 80
Description: qt-shutdown-p
 Is a Qt4-program to ...

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was reopened

Revision history for this message
hakaishi (hakaishi) said :

The problem was suddenly solved... don't know what did it -.-

Revision history for this message
hakaishi (hakaishi) said :

It seems the Problem wasn't solved. I just did "sudo pbuilder create".

Revision history for this message
hakaishi (hakaishi) said :

Form the IRC:
<maxb> hakaishi: PPAs will only resolve dependencies from the backports pocket if you configure them to do so. If that's the only problem with the package build, you can reconfigure your PPA and retry the build
<hakaishi> maxb: what do I need to configure? - And how?
<maxb> Go to your PPA's web page and click "Edit PPA Dependencies"