git import fails - symlink issues

Asked by Peter Bienstman on 2009-12-19

Git import fails for these two branches:

https://code.launchpad.net/~vcs-imports/mnemosyne-proj/max
https://code.launchpad.net/~vcs-imports/mnemosyne-proj/maemosyne

2009-12-19 11:40:24 INFO 52 bytes transferred |
2009-12-19 11:40:26 INFO Counting objects: 235, done. 0
2009-12-19 11:40:26 INFO finding revisions to fetch:generating index 0/235
2009-12-19 11:40:26 INFO finding revisions to fetch 1/136
2009-12-19 11:40:29 INFO
Traceback (most recent call last):
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/scripts/code-import-worker.py", line 63, in <module>
    script.main()
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/scripts/code-import-worker.py", line 58, in main
    import_worker.run()
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/lib/lp/codehosting/codeimport/worker.py", line 409, in run
    self._doImport()
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/lib/lp/codehosting/codeimport/worker.py", line 526, in _doImport
    bazaar_tree.branch.pull(foreign_branch, overwrite=True)
  File "<string>", line 4, in pull_write_locked
  File "/home/pqm/for_rollouts/production/eggs/bzr-2.1.0b3-py2.5-linux-x86_64.egg/bzrlib/branch.py", line 949, in pull
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/branch.py", line 416, in pull
    graph=graph)
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/branch.py", line 379, in update_revisions
    interrepo.fetch_objects(determine_wants, self.source.mapping)
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/fetch.py", line 493, in fetch_objects
    store, recorded_wants, pb)
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/fetch.py", line 363, in import_git_objects
    allow_submodules=getattr(repo._format, "supports_tree_reference", False))
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/fetch.py", line 255, in import_git_tree
    allow_submodules=allow_submodules)
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/fetch.py", line 255, in import_git_tree
    allow_submodules=allow_submodules)
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/fetch.py", line 255, in import_git_tree
    allow_submodules=allow_submodules)
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/fetch.py", line 245, in import_git_tree
    tree = lookup_object(hexsha)
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/fetch.py", line 303, in lookup_object
    return target_git_object_retriever[sha]
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/object_store.py", line 267, in __getitem__
    expected_sha=sha)
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/object_store.py", line 183, in _get_tree
    unusual_modes)
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/mapping.py", line 411, in directory_to_tree
    hexsha = lookup_ie_sha1(ie)
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/object_store.py", line 182, in <lambda>
    lambda ie: self._get_ie_sha1(ie, inv, unusual_modes),
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/object_store.py", line 161, in _get_ie_sha1
    return self._get_ie_object_or_sha1(entry, inv, unusual_modes)[0]
  File "/srv/importd.launchpad.net/production/launchpad-rev-8806/optionalbzrplugins/git/object_store.py", line 158, in _get_ie_object_or_sha1
    raise AssertionError("unknown entry kind '%s'" % entry.kind)
AssertionError: unknown entry kind 'symlink'
Import failed:
Traceback (most recent call last):
Failure: twisted.internet.error.ProcessTerminated: A process has ended with a probable error condition: process ended with exit code 1.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Martin Pool
Solved:
2010-01-28
Last query:
2010-01-28
Last reply:
2010-01-28

This is a bug in the upstream (bzr-git). It's fixed in the bzr-git trunk, but not integrated into Launchpad yet. I guess we'll definitely upgrade in the next rollout in January, but we can probably get the fix online faster if this is causing you problems.

Any idea when that rollout will be? At the moment it still fails...

Thanks!

Peter

Diogo Matsubara (matsubara) said : #3

Next rollout is scheduled to Wed, the 27th of January.

Best Martin Pool (mbp) said : #4

these branches now seem to be working

Thanks Martin Pool, that solved my question.