Please upgrade lp:openssh to 2a format

Asked by Colin Watson on 2009-12-18

Summary: Please upgrade lp:openssh (a.k.a. lp:~vcs-imports/openssh/main) to the 2a format, if you think this is a reasonable thing to do.

Background: I'm in the process of migrating my Debian package of openssh over to Bazaar. This is a somewhat laborious process, involving constructing Bazaar branches of some historical CVS branches using cscvs (since Launchpad doesn't deal with this itself), and then transforming my CVS history into appropriately-glued-together Bazaar branches using a hacked bzr-fastimport and a considerable amount of patience and swearing at CVS. I just got to the point where I was ready to push the first stage of this (the imported upstream branches) to Launchpad for safekeeping, only to realise that my local branches are 2a and I can't push them - at any rate not without disabling stacking, which will be bandwidth-intensive - since lp:openssh is a KnitPackRepository. My experiences with trying to mix the two formats have not in general been encouraging and I'm not wildly enthusiastic about trying to convert back, nor do I particularly want to redo the conversion work I've done so far.

I imagine that upgrading the branch will be a little disruptive to other users, but there are no other openssh branches registered on Launchpad and I rather suspect that I may in fact be its major user right now ... and at worst they'll have to make sure they're using a new enough version of bzr and upgrade their local branches to match. If upgrading the branch is OK with you, it would make my life somewhat easier.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
[LEGACY] Canonical WebOps Edit question
Solved by:
Michael Hudson-Doyle
Solved:
2009-12-23
Last query:
2009-12-23
Last reply:
2009-12-21

Hi Colin,

This requires a losa. I'll assign the question to them, but feel free to hassle Tom or someone if this doesn't get done :-)

Hi Losa,

Can you please log in to a code import slave and run:

sudo -u importd -H bzr log -l 1 sftp://hoover@escudero/srv/importd/www/00007270

Check that this has the same message as http://bazaar.launchpad.net/~vcs-imports/openssh/main/revision/head: (i.e., this is the right branch). Then run:

sudo -u importd -H bzr upgrade --2a sftp://hoover@escudero/srv/importd/www/00007270

I guess this'll take a few minutes, but probably not too many.

Thanks!

Michael

Tom Haddon (mthaddon) said : #2

This has been done.

Thanks, Tom

Colin Watson (cjwatson) said : #3

There's still something wrong here:

  $ bzr push -d 3.5 lp:~cjwatson/openssh/3.5
  Using default stacking branch /~vcs-imports/openssh/main at lp-64802192:///~cjwatson/openssh
  bzr: ERROR: KnitPackRepository('lp-64802192:///~vcs-imports/openssh/main/.bzr/repository')
  is not compatible with
  CHKInventoryRepository('lp-64802192:///~cjwatson/openssh/3.5/.bzr/repository')
  different rich-root support

https://code.launchpad.net/~vcs-imports/openssh/main still says "Branch format 6" and "Packs containing knits without subtree support".

Ah, sorry, I knew this but didn't say it: the upgrade I got Tom to do didn't propagate to the publicly accessible branch until the import was updated. I just forced an update, so the public branch is now in 2a format:

mwh@grond:config-manager$ bzr info nosmart+lp:openssh
Standalone branch (format: 2a)
Location:
  branch root: nosmart+bzr+ssh://bazaar.launchpad.net/~vcs-imports/openssh/main/
HPSS calls: 18 (18 vfs) SmartSSHClientMedium(connected=False, username=u'mwhudson', host='bazaar.launchpad.net', port=None)

Hope this works for you now.

Colin Watson (cjwatson) said : #5

Thanks Michael Hudson, that solved my question.