Merge Failed to merge two account

Asked by Amanpreet Singh Alam

I have four different mail ids, two merge correctly, but other two failed to merge properly
(tried various time to merge), tried to deactivate both, but still I am not able to merge
both those accounts.
Can you please help me?

Question information

English Edit question
Launchpad itself Edit question
Stuart Bishop Edit question
Last query:
Last reply:
Revision history for this message
Steve McInerney (spm) said :

Probably :-)
But you need to list the accounts you want merged, and the target for them all.


- Steve

Revision history for this message
Amanpreet Singh Alam (apreet-alam) said :

it is following
<email address hidden>
<email address hidden>

into -> <email address hidden>

Revision history for this message
Michael Barnett (mbarnett) said :

AS Alam,

The third email address you have listed there is for a deactivated account. I have reactivated this account to merge the other two in, but you will need to use the "forgot password" to log in.

Other than that you should be all set!


Revision history for this message
A S Alam (aalam-users) said :

All things are fixed, Now able to login with Reactivated account, but not able to open other than login page.
it seems to be effected with Problem.

Sorry, but I don't know where should I ask to fix it

Sorry, something just went wrong in Launchpad.

We’ve recorded what happened, and we’ll fix it as soon as possible.
Apologies for the inconvenience.

(Error ID: OOPS-1625M114)
as all merged a/c are not working, used another a/c.
Please suggest me if need to open new bug and where it should file'

Revision history for this message
Curtis Hovey (sinzui) said :

The script to move the merged accounts out of the way was run last week. This may require DB surgery to learn what is still wrong. The account does not have a preferred email address. Forgot password is supposed to set the email address to preferred.

  Module canonical.launchpad.webapp.login, line 354, in processPositiveAssertion
  Module canonical.launchpad.webapp.login, line 257, in login
    email = removeSecurityProxy(account.preferredemail).email
      AttributeError: 'NoneType' object has no attribute 'email

Revision history for this message
A S Alam (aalam-users) said :

just now I tried to do that (forget password), set preferred Email Address, changed password,
but still getting

Revision history for this message
A S Alam (aalam-users) said :

Please add my this a/c as Punjabi Team Admin If you can, as we need to work for Next release and need to add approve few contributor for this.


Revision history for this message
David Planella (dpm) said :

Amanpreet Singh Alam (LP apreet-alam) is the Ubuntu Punjabi translation team coordinator and team owner in Launchpad.

Right now the team owner account is deactivated and he's asked me for help.

Is there any way to move forward if a proper solution will require more time? Would it be possibly to temporarily transfer ownership of the team to his other working account (aalam-users), so that he can go on managing the team and adding new members if necessary?


Revision history for this message
Gary Poster (gary) said :

I have tried to reactivate your account, but I appear to be simply retracing the path that others have done before me.

I don't appear to have privileges to transfer ownership but will try to arrange for someone to do so.

Revision history for this message
Gary Poster (gary) said :

Reopened with reports of problem.

Revision history for this message
Gary Poster (gary) said :

aalam-users is now the owner of I'll create a bug and link it to this question later today.

Revision history for this message
A S Alam (aalam-users) said :


Can you help with this problem?

Provide an answer of your own, or ask Amanpreet Singh Alam for more information if necessary.

To post a message you must log in.