Redundant compilation errors

Asked by Emmanuel Milou

I am using Soyuz for nightly builds of sflphone software:

I have been getting a link error for 3 days now that I can't reproduce anywhere else. The compilator is trying to link against code that does not exist anymore (more precisely that is not compiled anymore). It seems like the object haven't been recompiled since I made these modifications and when trying to link, fails with undefined reference. Is there somewhere a compilation cache? That would explain why the obejct files are outdated.

Thank you


Question information

English Edit question
Launchpad itself Edit question
Registry Administrators Edit question
Solved by:
Julian Edwards
Last query:
Last reply:
Revision history for this message
Best Julian Edwards (julian-edwards) said :

It sounds like your source package is missing a build dependency. You need to check which package provides the library files you want to link against.

Revision history for this message
Emmanuel Milou (manumilou) said :

dpkg-buildpackage was stripping the optimization level (-O2), and the external library I am using need (?!) this, otherelse it crashes when linking.
Problem solved, thank you.