syntax highlight for scala

Asked by Parth Malwankar on 2009-11-08

Hello,

Launchpad does not seem to be highlighting scala syntax. E.g.:
http://bazaar.launchpad.net/~parthm/nazgul/trunk/annotate/head%3A/src/main/scala/oparg.scala
Its seems to work well for other languages like ruby and python.

When I try the same locally with loggerhead + pygments installed from packages (ubuntu 9.10) scala syntax highlight works beautifully.
Is this support planned?

Thanks,
Parth

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Gavin Panella
Solved:
2009-11-17
Last query:
2009-11-17
Last reply:
2009-11-16
Best Gavin Panella (allenap) said : #1

This might be because the version of python-pygments on the Launchpad machines is 0.9-2. Can you find out if Scala was supported in that version?

Launchpad is always run on the most recent LTS version of Ubuntu (8.04/Hardy). The next LTS is due out in April 2010, and Launchpad's servers will be upgraded a short time after that, so Scala support should arrive by then at the latest.

Parth Malwankar (parthm) said : #2

Thanks for the update Gavin.

This makes sense. It looks like Scala support came in version 0.11 (http://pygments.org/docs/changelog/#version-0-11-1) hence the lack of syntax highlight.

Parth Malwankar (parthm) said : #3

Thanks Gavin Panella, that solved my question.