Error importing remote git branch

Asked by L.Lopez on 2009-11-02

I'm getting errors while importing a git repostory into Launchpad.

The error is:
  bzrlib.plugins.git.fetch.SubmodulesNotSupported: Submodules can not yet be imported (requires nested tree support in Bazaar).

The remote git repository had one submodule when I first tried to import it, but now it doesnt have any submodule. May be it needs to be recreated?

Launchpad branch URL:
https://code.launchpad.net/~vcs-imports/eina/main-github

Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
Michael Hudson-Doyle Edit question
Last query:
2010-01-18
Last reply:
2010-01-18
Whiteboard:
2009-11-06 mrevell assigned to mwh
Jelmer Vernooij (jelmer) said : #1

The repository history still contains submodules. The first commit with submodules appears to be 6448af095a135571ce34ca85989f352fbaa89cf2

L.Lopez (ldotlopez) said : #2

Yes, it contains submodules in the past as I said.
But, this means it cant be imported? never?

Jelmer Vernooij (jelmer) said : #3

On Sat, 2009-11-07 at 10:48 +0000, xuzo wrote:
> Question #88128 on Launchpad itself changed:
> https://answers.edge.launchpad.net/launchpad/+question/88128
>
> Status: Answered => Open
>
> xuzo is still having a problem:
> Yes, it contains submodules in the past as I said.
> But, this means it cant be imported? never?
It can not be imported unless the commits that contain the submodules
are removed from the history or Bazaar starts supporting nested trees.

Cheers,

Jelmer

L.Lopez (ldotlopez) said : #4

Ok, I'm subscribed to lp bug #402814.
I hope this will be solved soon

L.Lopez (ldotlopez) said : #5

Is going launchpad.net to support git+subtree imports any time soon?

According to bug #402814 [1] support in bazaar is already done and launchpad.net and the fix already land on launchpad (comment #7 [2])

Logs from errors show different messages now, but I can't import my git branch yet. May be it needs some manual operation.

Can someone clarify this? Thanks!

1. https://bugs.launchpad.net/bzr/+bug/402814)
2. https://bugs.launchpad.net/bzr/+bug/402814/comments/7)

Jelmer Vernooij (jelmer) said : #6

Hi,

On Mon, 2010-01-18 at 11:42 +0000, xuzo wrote:
> Question #88128 on Launchpad itself changed:
> https://answers.launchpad.net/launchpad/+question/88128
>
> Status: Answered => Open
>
> xuzo is still having a problem:
> Is going launchpad.net to support git+subtree imports any time soon?
>
> According to bug #402814 [1] support in bazaar is already done and
> launchpad.net and the fix already land on launchpad (comment #7 [2])
>
> Logs from errors show different messages now, but I can't import my git
> branch yet. May be it needs some manual operation.
>
> Can someone clarify this? Thanks!
The required changes in bzr-git have landed, but there is still work
needed in Bazaar before imports with submodules can work. The bug you
are referring to still exists in Bazaar, it has only been marked "Fix
Released" for bzr-git.

Cheers,

Jelmer

Can you help with this problem?

Provide an answer of your own, or ask L.Lopez for more information if necessary.

To post a message you must log in.