Ubuntu Buildd and pbuilder problem

Asked by Charlie_Smotherman

I recently requested a sync of rlpr from debian to correct a FTBFS.

The package however FTBFS on the official ubuntu buildd's.

I built the package on my local machine in an up to date karmic pbuilder in which the build completed successfully.

I also built the package in my ppa in which it built successfully.

The question is why is rlpr building in my ppa and local machine and not on the official ubuntu build machines?

What is different on the ubuntu build machines that is not included in pbuilder?

How is one to know if a package will build successfully if the ubuntu build machines and pbuilder provide different results?

How is one to setup a local build system to mimic the ubuntu build machines? And yes I used --debootstrapopts --variant=buildd when setting up my pbuilder.

Is this a bug in launchpad, pbuilder, rlpr, or me? :)

Charlie Smotherman

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Jonathan Lange (jml) said :

I'm told that this has already been discussed in #ubuntu-devel, and that it turns out to be a bug in rlpr.

Revision history for this message
Julian Edwards (julian-edwards) said :

It's a package bug:

pkgstriptranslations: processing control file: ./debian/rlpr/DEBIAN/control, package rlpr, directory ./debian/rlpr
pkgstriptranslations: rlpr does not contain translations, skipping
pkgstriptranslations: The following PO/POT files are empty. This is known to
cause trouble in the translation importer and generally indicates a package

dh_builddeb: dpkg-deb returned exit code 1
make: *** [binary-arch] Error 1

The reason it doesn't fail in the PPA builds or locally for you is because the official builders call `pkgstriptranslations` which is failing as above.

Hope that helps!

Can you help with this problem?

Provide an answer of your own, or ask Charlie_Smotherman for more information if necessary.

To post a message you must log in.