Some packages of my PPA are not published!

Asked by Matthias Klumpp

I performed a test-build of my application "Listaller" (experimental build, do not use it). The debuild command creates the binary packages and a package listaller-data, containing all arch-independent data. All bin packages are published, but the -data package is missing although it was built:
dpkg-deb: building package `listaller-data' in `../listaller-data_0.3.11-1~exp2_all.deb'.

Why does this happen? Maybe it is a bug in my script, but it could also be a LP problem.


Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Max Bowsher
Last query:
Last reply:
Revision history for this message
Best Max Bowsher (maxb) said :

Hi Matthias,

The Launchpad build farm designates i386 as the one architecture on which arch-independent packages are built. As your build of listaller on i386 failed, the arch-indep packages were not created in this case.

Revision history for this message
Matthias Klumpp (ximion) said :

Thanks Max Bowsher, that solved my question.

Revision history for this message
Matthias Klumpp (ximion) said :

Ah, thank you! (Never thought about that!)