Submitted packages in PPA doesn't show up.

Asked by Oumar Aziz OUATTARA on 2009-09-20

Hi,

I am trying to submit packages to my PPA and I receive no confirmation/rejection email. Morover I don't see the package in the PPA page.

Here is my ppa definition in the dput.cf file:

[wattazoum-ppa]
fqdn = ppa.launchpad.net
method = ftp
incoming = ~wattazoum/ppa/ubuntu/
login = anonymous
allow_unsigned_uploads = 0

The package I am trying to submit is a patched version of samba (for intrepid).

 samba (2:3.2.3-1ubuntu3.5.xbmc1) intrepid; urgency=low
 .
   * apply samba fix for LP #315774.

I have noticed it with some other packages, usually when I try to patch an Ubuntu package.
I am also maintaining XBMC packages and those one are submitted correctly.

Any help would be appreciated .

Regards
Aziz

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Nelson
Solved:
2009-09-26
Last query:
2009-09-26
Last reply:
2009-09-24
Edwin Grubbs (edwin-grubbs) said : #1

Hi Aziz,

Is this the PPA you are having troubles with?
https://edge.launchpad.net/~wattazoum/+archive/ppa

When was the last time you were able to submit a package successfully?

Cheers,
Edwin

Hi,

Yes, It's the PPa you mentionned.
The last package I have uploaded successfully was uploaded the 2009-04-29

I also tried to upload the same kind of packages (patched ubuntu packages) to
https://edge.launchpad.net/~xbmc-addons/+archive/ppa and got the same problem.

Thank you for helping.
Aziz

Hi Aziz,

is it possible that you are - for one reason or another - using a key other than the one on your LP profile (id:9EE0115A) to sign the packages? (as outline at https://help.launchpad.net/Packaging/UploadErrors).

The reason I ask is that usually the only reason that you would not receive a confirmation/rejection email at all is if we cannot verify that the package actually came from you (ie. it's not signed with a key listed on your profile).

Sometimes this happens to people when they use a different machine which has a different key etc.

Let me know if this is not the case and we'll trouble-shoot further.

Thanks Michael Nelson, that solved my question.

This might probably the case. I used my Laptop to send those packages while I were using my Desktop to send XBMC packages.
Right 20 minutes ago I tried with my Desktop to send a patched Samba and it worked perfectly.