Import from bzr branch not occurring

Asked by Mark Lee on 2009-09-17

I'm trying to enable "automatic import from bzr branch" for the Awn 0.4 series <lp:awn/0.4>. However, I cannot seem to get the translation files to go into the import queue. I've tried the automatic method as well as the "Request Bazaar Import" method. As far as I know, the po (template) files are named appropriately.

FWIW, Export to branch works just fine.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
Jeroen T. Vermeulen Edit question
Solved by:
Jeroen T. Vermeulen
Solved:
2009-10-30
Last query:
2009-10-30
Last reply:
2009-09-26
Whiteboard:
No idea how to answer this one. I leave it in your hands jtv.
Adi Roiban (adiroiban) said : #1

Have you tried renaming the pot file to avant_window_navigator.pot ?

I don't know exactly how the import script works and if it also sets the domain name for a POT file and automaticaly convers hypens to underscores.

Jeroen T. Vermeulen (jtv) said : #2

Dashes are actually better than underscores, because template names in Launchpad can have the former but not the latter.

I don't see any reason why this shouldn't work. Import from a branch is triggered by changes to the branch. If the template was not updated since import from the branch was set up, you'll probably need to request a one-time import as well—or push a change to the branch.

Jeroen T. Vermeulen (jtv) said : #3

A clarification about the underscores: using underscores will work, but the template name as it will be displayed in Launchpad will convert them to dashes. Templates also have domains, which can have underscores; so you end up with underscores in the filename, dashes in the template name, and one of the two in the template domain. If you use dashes from the start, we can use the same spelling throughout, which is nicer and less confusing.

Mark Lee (malept) said : #4

I'm pretty sure that the PO template file and the PO files have been updated at least twice since the "import from the branch" configuration was set up, and I've pressed the "one-time import" button several different times.

Jeroen T. Vermeulen (jtv) said : #5

This looks like it may be caused by a generic problem with branch import processing, where some jobs get held up for a long time. I've alerted the Code team to it.

I've linked it to a bug. As a quick workaround, we'll just poke it a bit so your import job happens, and we'll work on the proper fix, hoping to have it in the next few days.

Henning Eggers (henninge) said : #7

Hi, we did some database magic now to get the job unstuck but it was not possible to restart it. Can you please request another import and tell us how it went?

https://translations.launchpad.net/awn/trunk/+request-bzr-import

Thank you for your patience.

Henning Eggers (henninge) said : #8

OK, we found the bug that caused us not to notice that the uploads are failing. The fix for that will be in today's 2nd roll-out.

But we still need to find out *why* it is failing. This seems to happen for particular branches only and yours is one of currently two affected branches. With this fix in we hope to be able to find out what is going on here but please don't expect a solution before next week.

I am really sorry for this.

Best Jeroen T. Vermeulen (jtv) said : #9

Update: the folks who are in charge of branches in Launchpad have found the reason why some of the jobs got stuck. It was a complex failure condition involving an error while reporting an error. Now that they've fixed that, we're able to see what the original failure message is.

The next step is to make sense of the failure. I think we'll be needing more help from the Code folks for that.

Mark Lee (malept) said : #10

It doesn't seem to be fixed...I've tried to request a one-time import twice in the past week, with no change in the state of translations in that series.

Mark Lee (malept) said : #11

It seems that I spoke too soon. My last import request finally went through.

Mark Lee (malept) said : #12

Thanks Jeroen T. Vermeulen, that solved my question.