How to report a bug with no package or project (Example: installing Ubuntu)

Asked by Ernst Zlo on 2009-09-09

1. When installing Ubuntu alpha 5, I found a little bug.
  But I don't know (and find) any package or project to refer to. (ubuntu-instal or ubuntu instal leads to no result)
  But without package or project no bug can be reported.

2. Some programs (for example gnome-keybinding-properties) have bugs but don't crash, for an unexperienced Ubuntu user like me, who don't know, which package is affected when a program doesn't do, what expected, it is very time expensive to search for bugs to find out, what package is affected. (especially as a non English native speaker)
It would be nice to have the chance to put in 'gnome-keybinding-properties' to find the right package.

++++++++++++++++++++
The bug in the install routine itself was:
While installing Ubuntu (alpha 5) Pidgin is featured [but as far as I see Empathy is installed] which could be a bit confusing to those 3 or 4, who read the text which is displayed while the installation is running ;-)

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Barry Warsaw
Solved:
2009-09-10
Last query:
2009-09-10
Last reply:
2009-09-09
Daniel Hollocher (chogydan) said : #1

Re: 1) I've been able to file bugs without a project by just filing against Ubuntu in general.

Re: 2) Here is how I find the package for a program of which I know the CLI name:
which <name of the command> (this gives you the location of the command)
dpkg -S <location of command>

See `man dpkg-query` for more info about the last command

Ernst Zlo (ernst-zlo) said : #2

Thank you very much, this helps a lot for programs which are installed and where I don't know the package. I've saved it to my howto's.

#1 filing against Ubuntu without package or project leads into either a Timeout Error (Error ID: OOPS-1348C2086) or in an error message, that package or project has to be filled out. Or am I missing here something?

But it does'nt solve the problem #2 anyway, if I see a bug (or misinformation in this exact case) - while the program is installed.

Because when I afterwards find out the package, it is in that special case useless, because the bug is not in the program itself, but in the installation routine. And when installing the complete Ubuntu system there is not a single program, where I can put my finger on it.

sorry for my bad explanation ...

(aarrrgh where's my English book <sigh>)

Best Barry Warsaw (barry) said : #3

Hi Ernst,

I'm sorry you've been having trouble with timeouts on Launchpad. It happens
occasionally and we try hard to fix them quickly. As you can see, I've opened
bug 426946 to track that problem.

danielhollocher is correct that the best way to submit a bug is to submit it
to Ubuntu itself and let the Ubuntu BugSquad triage it to the right project.

You also mention that you ran into this problem installing "Ubuntu alpha 5".
Does that mean you were trying to install the Karmic (9.10) alpha release when
you ran into problems?

Here are some links that might help you get farther.

https://wiki.ubuntu.com/UbuntuDevelopment
https://wiki.ubuntu.com/BugSquad
https://wiki.ubuntu.com/BugSquad/FAQ

Of course there is also the #ubuntu channel on Freenode.

I hope those resources can help you solve your problem.

Ernst Zlo (ernst-zlo) said : #4

Hi Barry,

If I would not be in beta testing teams since more then 30 years (Amiga) I would think that I've got mad [well, perhaps because I HAVE got mad ;-)]

I've just tested to file a bug with no package and no project and it is o.k. now (as I had to re-log.in just now and there was a hint 'This site is running pre-release code' I have the slight impresson that someone is working on the system just now <vvbg>

Yes It was Karmic and I have installed it about 25 times (trying out to enlarge and reduce partitions, install it multiple times in multiple partitions [all on VirtualBox, because I have real work to do on my PC)

so my problems are solved.

Thanks to all of you, it's really nice to have the same feeling again: kind people working hard and good to get an almost (no on can expect more) perfect product.

Ernst

Ernst Zlo (ernst-zlo) said : #5

Thanks Barry Warsaw, that solved my question.