Translation merging in 2.2.7: Why the branch has to be self-owned?

Asked by Savvas Radevic on 2009-07-27

I've set up a different branch under the group "timekpr-maintainers": ~timekpr-maintainers/timekpr/translations
I've also pushed the current lp:timekpr trunk to make it mergeable: https://code.launchpad.net/~timekpr-maintainers/timekpr/translations

I can't add a branch for translation merging that is owned by a group, the branch has to be owned by me. Why is that?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
David Planella
Solved:
2009-07-27
Last query:
2009-07-27
Last reply:
2009-07-27
Whiteboard:
20090727 allenap - Talked to dpm, who said "I've had a look, but I can't answer that one. I've moved the question to rosetta instead of lanuchpad and I'll let jtv1 answer it."
Best David Planella (dpm) said : #1

Hi Savvas,

Are you trying to use the new automatic merge of project translations to a Bazaar branch feature?

If that is the case, the Launchpad Translations devs tell me that it might be because the 2.2.7 rollout is still ongoing, so the feature is implemented (the code is in) but not yet operational.

Savvas Radevic (medigeek) said : #2

Thanks David Planella, that solved my question.

Savvas Radevic (medigeek) said : #3

That's the one, thank you!

The actual problem is in the announcement then. They announced it too quickly:
https://lists.ubuntu.com/archives/launchpad-announce/2009-July/000047.html

"Launchpd 2.2.7 was rolled out this past week" - "was rolled out" should be "is being rolled out" :)

Jeroen T. Vermeulen (jtv) said : #4

Most of 2.2.7 was rolled out this past week, but some crucial last fixes are only being rolled out right now, as I write this. I've asked the admins to set up the necessary fittings to get this operational as soon as possible after that.

Jeroen T. Vermeulen (jtv) said : #5

It should be possible to use a branch that's owned by a team (careful, we use the word "group" for specific other things in Launchpad) as long as you are a member of that team.

The reason that we require this is that we don't want to give people a way to overwrite files in other people's branches. :-)

Savvas Radevic (medigeek) said : #6

Noted, thanks!

Jeroen T. Vermeulen (jtv) said : #7

As it turns out, it's not quite possible to set a team-owned branch yet; see bug 407260.

The workaround is to make yourself the owner of the branch, set it as the translations export branch, and give it back to the team.