SSL Negotiation failed with SourceForge import

Asked by Albert Santoni on 2009-06-29

Hello,

I'm trying to import a branch from SVN hosted on SourceForge and it's failing with:
pysvn._pysvn_2_4.ClientError: PROPFIND request failed on '/svnroot/mixxx/!svn/vcc/default'
PROPFIND of '/svnroot/mixxx/!svn/vcc/default': SSL negotiation failed: Connection reset by peer (https://mixxx.svn.sourceforge.net)
Import failed:
Traceback (most recent call last):
Failure: twisted.internet.error.ProcessTerminated: A process has ended with a probable error condition: process ended with exit code 1.

Please see the branch:
https://code.launchpad.net/~vcs-imports/mixxx/features_sqlite

If anyone could please help us out with some backend magic, it would be greatly appreciated. :)

Thanks,
Albert (on behalf of the Mixxx team)

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
Paul Hummer Edit question
Solved by:
Albert Santoni
Solved:
2009-08-15
Last query:
2009-08-15
Last reply:
2009-07-30
Whiteboard:
2009-07-14 matsubara: Assigned to Michael for a manual code import after retrying a couple of times failed. 2009-08-12 henninge: Reminded Michael. The subject may have changed so this might warrent a new question to be opened. 2009-08-13 Julian: assigned to rockstar, Michael is away for a while.
Diogo Matsubara (matsubara) said : #1

I've updated the branch URL to use http instead of https. Let's see if it goes through

Albert Santoni (gamegod) said : #2

Hi Diogo,

Thanks for your attention to this matter. Unfortunately, it looks like
it's failed again:
https://code.launchpad.net/~vcs-imports/mixxx/features_sqlite

Thanks,
Albert

On Thu, Jul 2, 2009 at 12:08 AM, Diogo
Matsubara<email address hidden> wrote:
> Your question #75624 on Launchpad Bazaar Integration changed:
> https://answers.edge.launchpad.net/launchpad-code/+question/75624
>
>    Status: Open => Answered
>
> Diogo Matsubara proposed the following answer:
> I've updated the branch URL to use http instead of https. Let's see if
> it goes through
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.edge.launchpad.net/launchpad-code/+question/75624/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.edge.launchpad.net/launchpad-code/+question/75624
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Diogo Matsubara (matsubara) said : #3

Hi Albert,

a new import is now schedule. Let's retry it a few times and if it doesn't work I can contact one of the developers to do a manual code import.

Thanks and sorry for the inconvenience.

Emilien Klein (emilien-klein) said : #4

Hi Albert, Diogo and Michael,

I am adding my question here because I'm having the same problem importing (for the first time) a new project from SourceForge.
This is the branch that fails: https://code.launchpad.net/~vcs-imports/postlet/trunk

It sometimes fails fairly quickly (19 minutes, 12 minutes) but it usually goes on for a fair amount of time (1 hour 40, 2 hours, 3 hours) before failing. It consistently fails with this type of message:

PROPFIND of '/svnroot/postlet/trunk/Postlet/SRC/JAVA': SSL negotiation failed: Connection reset by peer (https://postlet.svn.sourceforge.net)

I know that the repository url is now using HTTPS, however if I believe the previous messages, changing it to HTTP might not ensure success, as I see that mixxx has still not succeeded in having a proper import, even after changing the protocol to HTTP.

Is this an issue that appears automatically on all new SourceForge projects? Does it require manual import?

Thanks,
Emilien Klein.

(In the future, please ask new Questions for new issues, it's much easier for us!)

The https -> http changes does not always work, no. But every time I've tried it, it's got much further, so let's give it a go this time too!

Emilien Klein (emilien-klein) said : #6

Well, it seems that after 3 hours and 50 minutes, the import was successful! So changing HTTPS to HTTP definitely helped!

P.S.: I added my question in this one because I think that people experiencing the same issue might find it handy to have one place for this specific problem, and the title of "SSL Negotiation failed with SourceForge import" was exactly my problem, so showed up as first result in Google. But I promise I'll open new questions in the future! ;)

Albert Santoni (gamegod) said : #7

While we're on the topic again, my Features_sqlite import still hasn't succeeded. Any ideas?

Thanks,
Albert

Albert Santoni (gamegod) said : #8

Hi guys, it looks like the SVN import magically succeeded a week or so ago. Not sure what anyone did that make that happen, but thanks to whoever did something behind the scenes. :)

Albert

Huh, I don't think I did anything (I was on holiday!). Happy it worked though!