Error mirroring lp:~mnordhoff/+junk/devel.btrees

Asked by Matt Nordhoff on 2009-06-17

I just added lp:~mnordhoff/+junk/devel.btrees, but there's an error:

"Launchpad has not been able to mirror this branch. The last attempt was 25 minutes ago. (Revision {[('Arch-1:<email address hidden>%pytz--devel--1--patch-2',)]} not present in ...) Launchpad will try again in 11 hours. If you have fixed the problem, please ask Launchpad to try again."

My guess is that it's because there's a ghost in the branch's history.

For what it's worth, the source branch is on a bzr+http server running bzr.dev r4445.

The odd thing is that Launchpad has mirrored dozens of branches of that project just fine. In fact, I just added 3 other copies of the exact same branch, in different formats, and 2 of them mirrored fine. (The other is in the 2a format, which LP doesn't support yet.)

lp:~mnordhoff/+junk/devel.2a
lp:~mnordhoff/+junk/devel.dev6rr
lp:~mnordhoff/+junk/devel.knits

Check is fine, "log -vp" seems to work, and I can branch it, including with bzr 1.14.1, which is what LP runs.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Aaron Bentley
Solved:
2009-06-23
Last query:
2009-06-23
Last reply:
2009-06-17
Best Aaron Bentley (abentley) said : #1

I've created a bug report. I confirm branching works for me as well.

Matt Nordhoff (mnordhoff) said : #2

Thanks Aaron Bentley, that solved my question.

Matt Nordhoff (mnordhoff) said : #3

I'm not sure what the proper protocol is, but I'll mark this as solved since my branch works now and the question has been superseded by the bug.