Error link in https://launchpad.net/~ubuntu-x-swat/+archive/xserver-no-backfill

Asked by ff670099 on 2009-06-16

There is an error in the following link:

https://launchpad.net/~ubuntu-x-swat/+archive/xserver-no-backfill

In the line: This repository is signed with 1024R/AF1CDFA9 OpenPGP key...
The link to the key (http://keyserver.ubuntu.com:11371/pks/lookup?search=0x643DC6BD56580CEB1AB4A9F63B22AB97AF1CDFA9&op=index) doesn't work.

Thank you

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-13
Last reply:
2009-11-16

This question was reopened

Aaron Bentley (abentley) said : #1

I just tested it and it works for me.

ff670099 (ff670099) said : #2

I have the following error:

ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: http://keyserver.ubuntu.com:11371/pks/lookup?

The following error was encountered:

    * Connection to 91.189.94.173 Failed

The system returned:

    (111) Connection refused

The remote host or network may be down. Please try the request again.

Your cache administrator is root.

I don't know what to do

ff670099 (ff670099) said : #3

If you find the key, may you paste it?

Thank you very much.

Jeroen T. Vermeulen (jtv) said : #4

This looks like a problem with your network, possibly a broken http proxy. The IP address you got seems to be correct, so chances are that the problem has solved itself by now.

If not, this is something to bring up with your internet provider.

The page you're trying to access shows:

Type bits/keyID Date User ID

pub 1024R/AF1CDFA9 2009-01-20 Launchpad PPA for Ubuntu-X

The key itself is:

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: SKS 1.0.10

mI0ESXVCiwEEANKBDbiSLOJOouub/S97iDifYCVW1b0KONg7XkFYiFos+bMBzzZyGGo90k1h
hCxcseLvqCKPL7dG0RzPRKMo7mvM68yyqi2ljw0ZYC9cVf0YzgKRTohVhihelpwZ+sBRGNYk
OCu+u0Dr+EdVI3u5RNOxAELrbd4vYaS+2cCOfzmLABEBAAG0GkxhdW5jaHBhZCBQUEEgZm9y
IFVidW50dS1YiLYEEwECACAFAkl1QosCGwMGCwkIBwMCBBUCCAMEFgIDAQIeAQIXgAAKCRA7
IquXrxzfqY4HBACIQEFhl59ZkuIhTD3pmCQgfkhpcg0RVdB6Xwhu3QDJvmlWmrs+cofNMzyA
7SwdjD9ARvhGbqHwub+T7oGiHlmFyodGypUZ4i/fdHsZYpsf34MwgYxhyNyOPY/jNImUE/yw
kSI+kV5esWURH4j0jYfkaergFqCpDnsSkxuIvdjH2Q==
=bkAa
-----END PGP PUBLIC KEY BLOCK-----

ff670099 (ff670099) said : #5

Thank you. It was a server problem.

ff670099 (ff670099) said : #6

I have one more problem: I installed ubuntu 9.10 but I have the same xserver problem. So I tried the same solution. How should I behave? Now the key isn't for karmic.

Thank you in advance

Ursula Junque (ursinha) said : #7

Hi,

I'm not sure I got your problem now. Adding the key should be simple as this:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9 (that's the key for the PPA you're trying to use)

And then, sudo apt-get update.

Can you try doing that and tell me if the problem still persists?

Thanks,

Ursula

ff670099 (ff670099) said : #8

The problem is that now I'm using ubuntu 9.10 and not 9.04. The key is for an other distro. I tried to change the repository jaunty to karmic but when I use the
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9

It doesn't work.

Thank you in advance

Ursula Junque (ursinha) said : #9

The key belongs to the repository :) So it won't change if you change the version of Ubuntu or the distro you're using.

What's the error message?

Thanks!

Ursula

ff670099 (ff670099) said : #10

The error is:

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9
gpg: richiesta della chiave AF1CDFA9 dal server hkp keyserver.ubuntu.com
gpgkeys: key AF1CDFA9 not found on keyserver
gpg: non sono stati trovati dati OpenPGP validi.
gpg: Numero totale esaminato: 0

In addition I don't know if I should use http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu karmic main or
http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu jaunty main

Thank you!

ff670099 (ff670099) said : #11

Does the xserver-no-backfill work for karmic or only for jaunty?

Gavin Panella (allenap) said : #12

Hi,

I suggest trying again - perhaps the keyserver.ubuntu.com server was having problems. If you still have no luck, you could try using the Authentication tab in Software Sources to import a key file. Failing that, please try asking for more help at https://answers.launchpad.net/ubuntu/+addquestion.

I can't see any problems in Launchpad or the Ubuntu keyserver at the moment, so I think the issue lies with your computer or the networks between your computer and keyserver.ubuntu.com.

Gavin.

Gavin Panella (allenap) said : #13

> Does the xserver-no-backfill work for karmic or only for jaunty?

Looks like the PPA has been built only for Jaunty. It may work for you in Karmic, but you should probably contact the Ubuntu-X team <https://edge.launchpad.net/~ubuntu-x-swat> for more information beforehand.

ff670099 (ff670099) said : #14

I asked some help to the Ubuntu-X-team.

Thank you for your help

Can you help with this problem?

Provide an answer of your own, or ask ff670099 for more information if necessary.

To post a message you must log in.