builds abort after ca. 10–17 minutes, no logs

Asked by Thorsten Glaser

I’ve had multiple builds abort after about ten minutes, with no logs showing up for another half hour or so.

Retrying them yielded the same result (except the jammy one which is still going after 14 minutes on its second try).

The twice failed ones are:

Hah, and (the jammy one) just terminated as well.

Could someone please investigate what’s happening there?

Thanks in advance!

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Colin Watson
Last query:
Last reply:
Revision history for this message
Best Colin Watson (cjwatson) said :

Thanks for the report. It looks like we missed an `ANALYZE` step when creating a couple of test rebuilds of Ubuntu, which meant that all PostgreSQL's statistics were way off and so lots of buildd-manager's performance-critical queries were running much more slowly than normal. We've rectified this and things seem happier now; I've retried your builds and they're building.

Revision history for this message
Thorsten Glaser (mirabilos) said :

Thanks Colin Watson, that solved my question.