Problème avec ppa

Asked by lann on 2009-05-10

Bonjour

J'ai réalisé un petit projet Guitar Tuner et ai mis le code source sur ce fabuleux site.
J'ai réalisé le paquet source pour la diffusion de mon logiciel.

La fabrication du paquet a fonctionné sur mon PC
Ce paquet fonctionne parfaitement sur mon PC
Malheureusement lorsque j'ai téléchargé sur votre site, la fabrication du paquet a échoué à cause de dépendances qui n'ont pu être trouvé (gtkmm 2.4 alsa etc..)

Donc 2 questions me viennent à l'esprit :
1/ J'ai modifié mon fichier control debian en rajoutant ${misc:Depends} dans Depends. Est-ce que ça suffira ?
2/ Comment intitulé la nouvelle version de mon paquet en sachant que l'ancienne version s'appelait guitartuner - 0.1.0-0ubuntu1 . Je ne voudrais pas changer le 0.1.0 car c'est la version de la branche.
ai-je bien numéroter mon paquet source dès le départ ?

D'avance Merci

Lann

Question information

Language:
French Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
lann
Solved:
2009-05-16
Last query:
2009-05-16
Last reply:
lann (lann) said : #1

Résolution des questions :

1/ Dans le fichier control du répertoire Debian, il faut mettre les noms exacts des dépendances (ex pour ALSA c'est libasound2-dev)

2/ J'ai changé l'appelation du paquet de guitartuner - 0.1.0-0ubuntu1 à guitartuner - 0.1.0-0ubuntu4 (4 essais pour que ça soit bon). Est-ce la bonne méthode ?

Maintenant j'ai réussi à compiler ce projet dans launchpad

wilfried (willfriednguessan) said : #2

idem pour moi c'est ce que j'avais fait.