s390x build fails due to out-of-memory issue

Asked by Luís Infante da Câmara

This build https://launchpad.net/~luis220413/+archive/ubuntu/security-updates/+build/24337106 is failing due to an out-of-memory issue that I encountered locally (on amd64), that can be worked around by reducing parallelism (at the cost of increased build times) or by increasing the available memory. The same source package builds successfully on all other architectures.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Luís Infante da Câmara
Last query:
Last reply:
Revision history for this message
Colin Watson (cjwatson) said :

The first set of errors in the log seems to be about syntax, not out-of-memory:

{standard input}: Assembler messages:
{standard input}:508070: Warning: end of file not at end of a line; newline inserted
{standard input}:509527: Error: bad expression
{standard input}:509527: Error: syntax error; expected ','
{standard input}:509527: Error: junk at end of line: `r'
{standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
{standard input}:508942: Error: value of fffffffffffe2142 too large for field of 2 bytes at 000000000001dec0
{standard input}:509355: Error: value of fffffffffffe1fc8 too large for field of 2 bytes at 000000000001e03a

I realize that there's "c++: fatal error: Killed signal terminated program cc1plus" just after that, but normally it's best to look at the first set of errors in the build log and consider that anything after that might well be just consequences.

The memory configuration for s390x builders is currently the same as for amd64 builders.

Revision history for this message
Luís Infante da Câmara (luis220413) said :

The errors are caused by truncation of the assembler's input, that is caused by abrupt termination of cc1plus. I will retry the build.

What are the memory configurations for the builders for each target architecture?

Revision history for this message
Colin Watson (cjwatson) said (last edit ):

The intended configuration is 8G RAM 4G swap on all architectures, but arm64/armhf/ppc64el are currently lacking swap due to the OpenStack oddity mentioned in https://answers.launchpad.net/launchpad/+question/694428. (Note that the summary in the ticket description is incorrect, and the amd64 issue mentioned in the last couple of comments on that ticket has been fixed.)

You can find this out for yourself by copying the "procenv" source package from Ubuntu, without existing binaries, into a PPA set to build for all available architectures; the resulting build logs will include a fair bit of information about each builder.

Revision history for this message
Luís Infante da Câmara (luis220413) said :

The build succeeded.