riscv64 snap builds failing to resolve ftpmaster.internal

Asked by Michał Sawicz

On more than a couple dozen builds since yesterday I saw:

E: Failed to fetch http://ftpmaster.internal/… Temporary failure resolving 'ftpmaster.internal'

A recent example:

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Michał Sawicz
Last query:
Last reply:
Revision history for this message
Jürgen Gmach (jugmac00) said :
Revision history for this message
Colin Watson (cjwatson) said :

This was a very weird regression that had something to do with an `apt full-upgrade` of the base image, which left containers without an IP address. I reverted to the previous image and just upgraded launchpad-buildd on its own, and that seems to have fixed it; I'll try to narrow it down more carefully before upgrading again.

Revision history for this message
Colin Watson (cjwatson) said :

I've also mass-retried all the snap builds that failed for reasons that might have been something to do with this.

Revision history for this message
Michał Sawicz (saviq) said :