ppa don't take build-deps from other ppa packages

Asked by Fantu

Yesterday I created a new PPA: https://launchpad.net/~fantonifabio/+archive/ubuntu/muffin-rebase/ that require another for build: https://launchpad.net/~linuxmint-daily-build-team/+archive/ubuntu/daily-builds
cinnamon packages require muffin from my (same) ppa on build, yesteday 1 time failed because was not yet published (taken long time before build complete), today I updated muffin and cinnamon but cinnamon still failing build for missed muffin even if already published:
sbuild-build-depends-cinnamon-dummy : Depends: libmuffin-dev (>= 5.2) but it is not going to be installed
I already retried other time but same issue.
Is a temp. launchpad issue and will resolve itself or I need do something to workaround/solve it?
thanks for any reply and sorry for my bad english

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Colin Watson
Last query:
Last reply:
Revision history for this message
Best Colin Watson (cjwatson) said :

"... but it is not going to be installed" is apt's way of saying that your build-dependencies are not installable. In other words, it's trying to install the package from your PPA, but it can't because its dependencies aren't satisfiable. To debug this, enable your PPA in a test environment, attempt to install libmuffin-dev, and then add additional packages from "is not going to be installed" error messages to the "apt install" command line until it gives a more useful message.

In this case, it's because your libmuffin-dev package is broken and cannot be installed. It declares both "Depends: libmuffin0" and "Breaks: libmuffin0", which is contradictory. The usual reason to declare a Breaks/Replaces pair is to indicate that you're moving files from another package to the breaking/replacing one; if that's what you're doing here, you need to add a "<<" version constraint to both "Breaks: libmuffin0" and "Replaces: libmuffin0" giving the earliest version that no longer contains the files being moved. However, I haven't looked into your packaging in detail.

In any case, it isn't a Launchpad issue that it can't install uninstallable build-dependencies.

Revision history for this message
Fantu (fantonifabio) said :

thanks for reply, I didn't add the version to break/replace to make possible to upgrade from build of same version without the package split (if someone have tested it with manual build before) now I added it and retried build but still failed:
I don't understand why

Revision history for this message
Fantu (fantonifabio) said :

sorry for my stupid error, version with ~ is minor so the break/replace is still a "block"

Revision history for this message
Fantu (fantonifabio) said :

Thanks Colin Watson, that solved my question.