What determines the sync delay when packages are copied between PPAs?

Asked by Adrianna Pińska

My project has a testing PPA where packages are uploaded for internal testing within the development team, and a public PPA where the packages are made available to everyone.

When I created the testing PPA, I copied some dependency packages into it from the public PPA, and this worked instantaneously, as I expected. I then pushed source packages to the testing PPA to be built.

When the packages were ready for publication in the public PPA, I opted to copy the built binaries from the testing PPA instead of re-uploading source packages directly to the public PPA, expecting that this would be much faster because I wouldn't have to wait for the packages to be rebuilt. However, it has now been several hours, and the packages are still not published in the destination PPA, and I have no indication at all of how much longer it's expected to take.

Is there any way to get an estimate of this delay, and/or any way to short-circuit the process? I don't know what will happen if I try to re-upload the same packages or try to delete them first and then upload them, and don't want the PPA to end up in an inconsistent state or to have to bump the version because packages with the same version will be rejected.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Adrianna Pińska
Last query:
Last reply:
Revision history for this message
Tom Wardill (twom) said :


We've currently got an outage in the process that does the publishing for PPAs, which explains the delay you are seeing. Usually it should be a few minutes.
Re-uploading will not currently help, as the entire publishing process is stuck.

We're working to fix this now, so hopefully good shortly, though there will be a backlog to process afterwards.

Sorry about this!

Revision history for this message
Adrianna Pińska (confluence) said :

Thank you very much for the prompt response. I will wait!

Revision history for this message
Tom Wardill (twom) said :

Just as I typed that, it was fixed.
The process has a bit of a queue to work through, but you should see the change happen soon, although I can't tell you how 'soon' soon is, unfortunately.

Sorry for the wait!