Unable to upload large files

Asked by Timo Vanwynsberghe

I've been getting a 502 error in the last few days when uploading certain files. It seems to be related to their file size. Here's some details:

* The full error: https://pastebin.com/W4MinBRA
* This is both through the web interface and launchpadlib
* A 5 mb tar.gz file uploads without problem
* A 36 mb zip file fails
* A 74 mb dmg file fails
* Uploading very similar files worked fine a year ago
 * The URL I'm trying to upload files to: https://launchpad.net/pigeonplanner/4.2/4.1.1

cjwatson mentioned on IRC yesterday that it might be due the gunicorn default 30 seconds timeout, so I just checked and uploads fail indeed at the 30 seconds mark.

Question information

English Edit question
Launchpad itself Edit question
Colin Watson Edit question
Last query:
Last reply:
Revision history for this message
Colin Watson (cjwatson) said :

I've proposed a change to our configs to raise the gunicorn timeout to 65 seconds, which is higher than the per-page timeout here and so should fix this. (The change is https://code.launchpad.net/~cjwatson/lp-production-configs/raise-gunicorn-timeouts/+merge/407025 - that's a private link so you won't be able to see it, but posting it here for reference.)

Revision history for this message
Hb (hbb) said :

Since some days I get an error "Technically, the load balancer took too long to connect to an application server." when trying to upload a 3 MB po file.

Revision history for this message
Hb (hbb) said :

The time span for uploading a file is to short. Uploading a 3 MByte file failed while uploading a 945 Byte file worked.

Can you help with this problem?

Provide an answer of your own, or ask Timo Vanwynsberghe for more information if necessary.

To post a message you must log in.