PPA rejects packages with out-of-disk, but reports 9GB free space

Asked by Péter Szilágyi on 2021-04-08

Hello,

For about 10 days now all our uploaded source package have been rejected with:

```
Rejected:
PPA exceeded its size limit (12568.00 of 12288.00 MiB).
```

However, the PPA reports we have over 9GB of free space https://launchpad.net/~ethereum/+archive/ubuntu/ethereum/+packages:

```
Package totals
The following information is related to the total published packages in the repository (not on your system).

Number of packages:
24 source packages (2.0 GiB)
300 binary packages (1.2 GiB)
Repository size:
3.2 GiB (26.61%) of 12.0 Gi
```

Help?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Péter Szilágyi
Solved:
2021-04-08
Last query:
2021-04-08
Last reply:
2021-04-08
Colin Watson (cjwatson) said : #1

We had a spam attack that for complicated reasons prevented us from running the task that removes superseded packages from PPAs (we're working to prevent this being a problem in future). We were able to re-enable that task yesterday, and:

2021-04-07 22:36:30 INFO Processing http://ppa.launchpad.net/ethereum/ethereum/ubuntu
2021-04-07 22:36:49 INFO Removing 694 files marked for reaping
2021-04-07 22:36:49 INFO Total bytes freed: 9569511233

However, the last upload attempt to that PPA was on 2021-04-06.

In short, this should be fine if you just try again now.

Péter Szilágyi (karalabe) said : #2

Ah, thank you. Can confirm that it works now. We were just getting ready to push our releases and wanted to make sure it will go through. It was our fault that we didn't push unstable builds for the past 2 days.