All source package recipe pages report 'timed out'

Asked by Dan Streetman on 2021-04-05

For about a week now, all source package recipe pages have consistently reported 'timed out' error for me. This includes all personal recipes as well as all team recipes, e.g.:

https://code.launchpad.net/~ddstreet/+recipe/systemd-next-b
https://code.launchpad.net/~ddstreet/+recipe/systemd-next-f

and

https://code.launchpad.net/~ubuntu-support-team/+recipe/systemd
https://code.launchpad.net/~ubuntu-support-team/+recipe/crash

I can view the list of recipes, as well as the ppas they build into, and they are still building daily, and I'm still getting email for any failed builds.

Is this a bug or am I doing something wrong?

An example from one of the failed page loads is the text:

Timeout error
Sorry, something just went wrong in Launchpad.

We’ve recorded what happened, and we’ll fix it as soon as possible. Apologies for the inconvenience.

Trying again in a couple of minutes might work.

If you report this as a bug, please include the error ID below, preferably by copying and pasting it rather than by taking a screenshot.

(Error ID: OOPS-25f4890f71af460e9a70225a7e1b03fd)

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Dan Streetman
Solved:
2021-04-07
Last query:
2021-04-07
Last reply:
2021-04-06
Tom Wardill (twom) said : #1

These are loading for me, are they still a problem for you?

I don't think you're doing something wrong, but it might be to do with your account (number of team memberships/subscriptions has caused this sort of thing in the past).

Colin Watson (cjwatson) said : #2

It may also be related to an archive spam attack. But if it's still happening, do use the "Create bug report" option to convert this into a bug so that the OOPS ID is preserved.

Dan Streetman (ddstreet) said : #3

> These are loading for me, are they still a problem for you?

strange, it does still timeout for me, but when i tried it in an incognito chrome window it works...so i assume something to do with my browser cache and/or login session...

I'll try clearing my cache and cookies and logging out/in to see if that fixes it.

Dan Streetman (ddstreet) said : #4

Ok so I confirmed that logging it lets me view the page again, and when I log in it times out again, even when i login from the incognito window.

So it's something specific to my launchpad account that's causing access to all launchpad recipe pages to timeout...I'll convert this to a bug report.

Dan Streetman (ddstreet) said : #5

hurray! whatever was causing the issue seems to be 'fixed' now; i'm able to access my recipe pages.