Can't make ~multipass-team public, since "it is referenced by a snapbuild"

Asked by Michał Sawicz on 2021-02-12

Trying to make ~multipass-team public, but getting an error:

> This team cannot be converted to Public since it is referenced by a snapbuild.

<cjwatson> I wonder why multipass-team was the requester of some snapbuilds. That seems pretty odd, normally requesters are actual people

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2021-02-12
Last reply:
2021-02-12
Colin Watson (cjwatson) said : #1

This is due to multipass-team being the requester of https://launchpad.net/~mir-team/+snap/mir-kiosk-beta/+build/268285 and a few others (for whatever reason). Having established this, please press the "Create bug report" button on this question - I think we're going to need to tweak the visibility checks here to skip the snapbuild.requester column (which I don't believe can leak team membership information).

Can you help with this problem?

Provide an answer of your own, or ask Michał Sawicz for more information if necessary.

To post a message you must log in.